Bug 584725 - Default results choise in personal preferences
Summary: Default results choise in personal preferences
Status: CLOSED NOTABUG
Alias: None
Product: Beaker
Classification: Community
Component: web UI   
(Show other bugs)
Version: 0.5
Hardware: All
OS: Linux
medium
low vote
Target Milestone: ---
Assignee: Raymond Mancy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-22 09:44 UTC by Zbysek MRAZ
Modified: 2015-05-04 02:20 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-27 16:50:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zbysek MRAZ 2010-04-22 09:44:04 UTC
I don't like pretty much the way how the results are showed - the default is failed items only. 

The page should even remember the previous selection (not return to default everytime the page reloads) or there should be the choise in personal preferences for every user to choose which selection of results he wants to see.

Comment 1 Ales Zelinka 2010-04-22 16:16:34 UTC
One more problem with the default choice:

https://beaker-stage.app.eng.bos.redhat.com/recipes/953#task4829

This is link to a task results number 4829 but when you open it tasks 4830 and 4831 are displayed. I guess the cause is that 4829 has PASSed thus gets filtered out and 4830 is the first failing task in the job after 4928...

Quite confusing.

Comment 2 Bill Peck 2010-04-24 14:27:25 UTC
I've changed the default display to be compressed and it gives you the choice to display all results or only failed results (if there are failed results).

I think I still need to deal with the linking which is mentioned in comment 1.

The changes are live on beaker-stage, can you please check if this is a step in the right direction?

Thanks

Comment 3 Zbysek MRAZ 2010-04-24 19:39:02 UTC
Yes, that's maybe even better, when you are looking for particular acrhitecture for example. Thank you.

Comment 4 David Kovalsky 2011-01-25 13:44:26 UTC
A few things have changed since this report has been filed. Is there actually anything else requested or can we close this out?

Comment 5 Zbysek MRAZ 2011-01-25 14:34:16 UTC
I'm pretty much happy with current state. This can be closed from my point of view.

Comment 6 David Kovalsky 2011-01-25 15:02:54 UTC
Great :) Ales (and everyone else), any objections to closing this bug?

Comment 7 Ales Zelinka 2011-01-27 14:10:54 UTC
Nope, +1 to closing this bug.


Note You need to log in before you can comment on or make changes to this bug.