Bug 58480 - /usr/share/man/man is bogus
Summary: /usr/share/man/man is bogus
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdeutils   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-17 20:55 UTC by msterret
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-18 18:46:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
removes the bogus man/man tree and the efax man pages (632 bytes, patch)
2002-01-18 18:45 UTC, msterret
no flags Details | Diff

Description msterret 2002-01-17 20:55:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20011220

Description of problem:
The kdeutils-2.2-2 rpm includes the following bogus files:

/usr/share/man/man
/usr/share/man/man/man1
/usr/share/man/man/man1/efax.1.gz
/usr/share/man/man/man1/efix.1.gz
/usr/share/man/man/man1/fax.1.gz

Looks like a spec file problem.  The presence of this bogus directory
structure causes man -K to spit out the following error message:

man -K blah  
grep: /usr/share/man/man/man1: Is a directory


Version-Release number of selected component (if applicable):
kdeutils-2.2-2

How reproducible:
Always

Steps to Reproduce:
1. rpm -ql kdeutils-2.2-2 | grep man
	

Actual Results:  /usr/share/doc/HTML/en/kljettool/djcdoscommands.txt
/usr/share/man
/usr/share/man/man
/usr/share/man/man/man1
/usr/share/man/man/man1/efax.1.gz
/usr/share/man/man/man1/efix.1.gz
/usr/share/man/man/man1/fax.1.gz


Expected Results:  maybe:

/usr/share/doc/HTML/en/kljettool/djcdoscommands.txt
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/efax.1.gz
/usr/share/man/man1/efix.1.gz
/usr/share/man/man1/fax.1.gz

but efax has it's own package so I'm not sure.

Additional info:

Comment 1 Bernhard Rosenkraenzer 2002-01-17 21:26:36 UTC
The right solution is to simply remove the man pages, they got there by accident and should come from the efax package only.
This has been fixed in rawhide for a couple of weeks.



Comment 2 msterret 2002-01-18 18:45:29 UTC
Created attachment 42836 [details]
removes the bogus man/man tree and the efax man pages

Comment 3 msterret 2002-01-18 18:46:24 UTC
kdeutils-2.2.2-1.src.rpm in rawhide still has this problem.

I've attached a patch to the spec file that "fixes" the problem for me although
it's all pretty hacky in there.

Comment 4 Bernhard Rosenkraenzer 2002-01-18 18:54:18 UTC
Where did you find rawhide with kdeutils 2.2.2-x?

Rawhide is at 3.0.0-0.cvs20020117.1 and has been at various 3.0.0 snapshots
before that.
This was fixed in the first 3.0.0 package a couple of weeks back.

Comment 5 msterret 2002-01-18 19:04:43 UTC
ftp://ftp.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS/kdeutils-2.2.2-1.src.rpm

I assumed that kde 2.x would be run in parallel to 3.x and that the source rpm
for 2.2.2 was still current.

Sorry for the mess.

Comment 6 Bernhard Rosenkraenzer 2002-01-18 19:06:49 UTC
I'll ask the ftp people to fix this problem - it shouldn't be there, they're
conflicting (both want to own the same files).


Note You need to log in before you can comment on or make changes to this bug.