Bug 585051 - Panel transparency fails to gibberish after hiding
Summary: Panel transparency fails to gibberish after hiding
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-nouveau
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ben Skeggs
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-23 01:25 UTC by Dan Beard
Modified: 2010-07-16 05:00 UTC (History)
0 users

Fixed In Version: xorg-x11-server-1.7.5-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-16 05:00:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
Log file-dmesg (48.12 KB, text/plain)
2010-04-28 05:04 UTC, Dan Beard
no flags Details
Xorg.0.log (74.01 KB, text/plain)
2010-04-28 05:05 UTC, Dan Beard
no flags Details
System-log (82.01 KB, text/plain)
2010-04-28 05:05 UTC, Dan Beard
no flags Details

Description Dan Beard 2010-04-23 01:25:14 UTC
Description of problem: Panel transparency fails to gibberish after hiding


Version-Release number of selected component (if applicable):
RHEL 6 Beta

How reproducible:
Set bottom panel to 50% transparent, then hide it.   Upon re-display, transpaerncy is gone and in its place is assorted bits of display of other open windows, repetitive paterns etc.

Steps to Reproduce:
1.Set bottom panel to 50% transparent
2.Set panel to auto hide, allow it to hide.
3.Retrieve panel by mouse.
  
Actual results:
A mess!

Expected results:
clean transparency

Additional info:
Gforce GTS 250 video card (1 gig - DDR3)
AMD Phenom II x4 964 C3
Gigabyte GA-790FXTA-UD5 MOtherboard 8 gigs DDR3 RAM

Comment 2 RHEL Program Management 2010-04-23 02:54:20 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Matěj Cepl 2010-04-27 15:39:19 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach

* your X server config file (/etc/X11/xorg.conf, if available),
* output of the dmesg command,
* system log (/var/log/messages), and
* X server log file (/var/log/Xorg.*.log)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 4 Dan Beard 2010-04-28 05:04:37 UTC
Created attachment 409659 [details]
Log file-dmesg

xorg.conf does not exist.

I've truncated the system-log to today's boot only.

Comment 5 Dan Beard 2010-04-28 05:05:14 UTC
Created attachment 409660 [details]
Xorg.0.log

Comment 6 Dan Beard 2010-04-28 05:05:41 UTC
Created attachment 409661 [details]
System-log

Comment 9 Ben Skeggs 2010-04-28 06:07:21 UTC
You Xorg.0.log indicates you're using xorg-x11-server-1.7.5-1.el6 which has a known bug that's very similar to this.  The bug was fixed in 1.7.5-2.

Is the issue resolved after an update?

Comment 10 Dan Beard 2010-04-28 11:21:10 UTC
Morning, Ben.

Nope.   Still the same.   In fact, there's only one update available so far, (since the install) and that is a chinese language pack.

Comment 11 Ben Skeggs 2010-07-07 23:35:37 UTC
Have you been able to try this with beta2?  The necessary updates should be there.

Comment 12 Dan Beard 2010-07-14 07:09:10 UTC
Morning, Ben.

I have not installed Beta2.   Is there any way to update into it?   I had an HDD fail recently, and a good sized chunk of data got saved to the Beta1 partition.   I am therefore reticent to immediately install Beta2 over it.

Comment 13 Ben Skeggs 2010-07-15 00:00:34 UTC
Do you see any updates from yum now that beta2 is released?

Comment 14 RHEL Program Management 2010-07-15 14:56:17 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 15 Dan Beard 2010-07-15 16:13:17 UTC
Afternoon, Ben.   Sorry it took a while.   

I'm in RHEL Beta6 now, and I can see no updates here at all save a chinese language package.

If you'll walk me through it, I'll get the repos straightened out and get this updated.

My yum.repos.d contents is listed below.




rhel-beta.repo:

[rhel-beta]
name=Red Hat Enterprise Linux $releasever Beta - $basearch
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/$basearch/os/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

[rhel-beta-optional]
name=Red Hat Enterprise Linux $releasever Beta (Optional) - $basearch
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/optional/$basearch/os/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

[rhel-beta-source]
name=Red Hat Enterprise Linux $releasever Beta - $basearch - Source
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/source/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

[rhel-beta-optional-source]
name=Red Hat Enterprise Linux $releasever Beta (Optional) - $basearch - Source
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/optional/source/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

[rhel-beta-debuginfo]
name=Red Hat Enterprise Linux $releasever Beta - $basearch - Debuginfo
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/$basearch/debuginfo/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

[rhel-beta-optional-debuginfo]
name=Red Hat Enterprise Linux $releasever Beta (Optional) - $basearch - Debuginfo
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/optional/$basearch/debuginfo/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

Comment 16 Ben Skeggs 2010-07-15 23:32:00 UTC
ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/$basearch/os/

My thoughts are to change $releasever to 6Workstation-beta2 perhaps?  Either that or to create a new repo file pointing at it.

Comment 17 Dan Beard 2010-07-16 02:09:01 UTC
Ok.   That gave me enough info to surf in and get something that will work.   

*Sigh!*   Now I spend all night watching it update!   :-P  

I'll get back to you with the results.


Thanks!

Comment 18 Dan Beard 2010-07-16 04:48:50 UTC
Well ... that fixed this bug so we can close it ... but it seems to be popping regular Kernel crashes now.   Bug that's a bug for a different stew.

Ah, well.   That's life in fedora/Redhat update land.   Wouldn't want to get bored with it all, now would we?   :-D

Comment 19 Ben Skeggs 2010-07-16 05:00:39 UTC
While it's unfortunate you're having kernel issues now, I'm glad this bug is resolved :)

Thank you for testing!


Note You need to log in before you can comment on or make changes to this bug.