Bug 585079 - [abrt] crash in gnome-activity-journal-0.3.3-1.fc13: view.py:142:jump:IndexError: list index out of range
[abrt] crash in gnome-activity-journal-0.3.3-1.fc13: view.py:142:jump:IndexEr...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-activity-journal (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Mads Villadsen
Fedora Extras Quality Assurance
abrt_hash:c8f02154
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 01:09 EDT by David Le Sage
Modified: 2010-08-11 14:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 14:51:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (507 bytes, text/plain)
2010-04-23 01:09 EDT, David Le Sage
no flags Details

  None (edit)
Description David Le Sage 2010-04-23 01:09:27 EDT
abrt 1.0.9 detected a crash.

architecture: i686
cmdline: python /usr/share/gnome-activity-journal/gnome-activity-journal
component: gnome-activity-journal
executable: /usr/share/gnome-activity-journal/gnome-activity-journal
kernel: 2.6.33.1-19.fc13.i686.PAE
package: gnome-activity-journal-0.3.3-1.fc13
reason: view.py:142:jump:IndexError: list index out of range
release: Fedora release 13 (Goddard)

backtrace
-----
view.py:142:jump:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/share/gnome-activity-journal/src/main.py", line 205, in moveback
    self.activityview.jump(-86400)
  File "/usr/share/gnome-activity-journal/src/view.py", line 142, in jump
    diff = self.start - self.cal.histogram.get_datastore()[0][0]
IndexError: list index out of range

Local variables in innermost frame:
self: <ActivityView object at 0xa42c34c (src+view+ActivityView at 0xa3c4210)>
offset: -86400
Comment 1 David Le Sage 2010-04-23 01:09:29 EDT
Created attachment 408493 [details]
File: backtrace
Comment 2 Mads Villadsen 2010-08-11 14:51:40 EDT
I am unable to reproduce this. If you can provide a step-by-step guide on how to trigger this problem, please feel free to reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.