Bug 585143 - RFE: Links to uploaded files independent on directory structure
Summary: RFE: Links to uploaded files independent on directory structure
Status: CLOSED NOTABUG
Alias: None
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
(Show other bugs)
Version: 0.5
Hardware: All Linux
low
low vote
Target Milestone: ---
Assignee: Raymond Mancy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-23 09:02 UTC by Marian Csontos
Modified: 2014-12-08 01:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 14:19:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marian Csontos 2010-04-23 09:02:27 UTC
Description of problem:

Accessing log files through following link is fine, but these link will break every time we change directory structure.
https://beaker.redhat.com/logs/2010/51/451/817/4026///task_log
(It's the 2010/51 part I do not like...)

Could we access log files in more independent way - e.g.
https://beaker.redhat.com/job/451/logs/817/4026///task_log
https://beaker.redhat.com/recipe/817/logs/4026///task_log

Or just:
https://beaker.redhat.com/logs/451/817/4026///task_log

Version-Release number of selected component (if applicable):
0.5.25

Comment 1 Bill Peck 2010-04-23 13:11:58 UTC
I don't understand the problem here.  This is so we can easily migrate old test results based on the age of the logs onto other storage.

2010/51 will not change once the recipe is started.

Comment 2 Marian Csontos 2010-04-23 14:08:49 UTC
I have absolutely nothing against the actual directory layout. I have thought of a perma-link feature.

The problem is these paths have changed several times now, and I expect the will change again (proof by mathematical induction).

For WebUI it does not matter that much, but e.g. for linking from BZ that is a problem.

Comment 3 Bill Peck 2010-04-23 14:18:46 UTC
They changed once.  I added the year.


Upload logs to bugzilla.  don't link.

Comment 4 Marian Csontos 2010-04-23 14:56:52 UTC
Oh, indeed. The other change (adding hundreds) was on rhts. Sorry.


Note You need to log in before you can comment on or make changes to this bug.