Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585214 - use DEVTYPE to ignore WWAN ethernet devices
use DEVTYPE to ignore WWAN ethernet devices
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 08:52 EDT by Gregor Gruener
Modified: 2014-12-14 20:02 EST (History)
2 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-0.1.git20100510.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 19:50:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (96 bytes, text/plain)
2010-04-23 08:52 EDT, Gregor Gruener
no flags Details
lsusb -v (10.68 KB, text/plain)
2010-04-23 08:53 EDT, Gregor Gruener
no flags Details

  None (edit)
Description Gregor Gruener 2010-04-23 08:52:34 EDT
Created attachment 408601 [details]
lspci

Description of problem:
I have an internal bluetooth/wlan modul. I like to install my notebook via PXE boot and at the beginning of the installation when I like to configure the network card via DHCP or manuall the NetworkManager will try to configure usb0 device and the installation will aborted. When I disabled the bluetooth/wlan modul on the notebook, Anaconda find the eth0 device and the installation is running well.

Version-Release number of selected component (if applicable):
NetworkManager default release on Fedora 12

How reproducible:


Steps to Reproduce:
1. Activate internal bluetooth/wlan modul on notebook
2. PXE boot Fedora 12 x64
3. At the beginning of the installation how you like to configure your network-device via DHCP or manuell, NetworkManager will try to configure usb0 device and abort the installation process.
  
Actual results:
I deactivated the bluetooth/wlan modul for the installation.

Expected results:


Additional info:
Comment 1 Gregor Gruener 2010-04-23 08:53:06 EDT
Created attachment 408603 [details]
lsusb -v
Comment 2 Gregor Gruener 2010-04-24 07:40:25 EDT
One more additional information, I have an integrated UMTS-Card device too and I think the UMTS-Card was detected as usb0.

lsusb output:
Bus 004 Device 002: ID 0a5c:2145 Broadcom Corp.
Bus 002 Device 002: ID 0bdb:1900 Ericsson Business Mobile Networks BV
Comment 3 Dan Williams 2010-04-25 03:47:10 EDT
Yeah, we need to use the new DEVTYPE uevent item to ignore mobile broadband ethernet devices as real devices, since while they are ethernet interfaces, these interfaces require setup from the serial port before they become live.  And that requires ModemManager, which I'm pretty sure isn't shipped on the stage2 anaconda install bits.  NM already has the logic to ignore fake ethernet devices that are part of modems, but what tells NM that they are part of a mdoem is ModemManager.

But we can work around this for many devices by using DEVTYPE.
Comment 4 Dan Williams 2010-04-25 12:53:13 EDT
upstream fix is:

9b944dec961e06865c622fbaf597ac35353f26a0
Comment 5 Fedora Update System 2010-04-27 03:56:24 EDT
NetworkManager-0.8.0-8.git20100426.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc13
Comment 6 Fedora Update System 2010-04-27 03:57:12 EDT
NetworkManager-0.8.0-8.git20100426.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc12
Comment 7 Fedora Update System 2010-04-27 21:15:31 EDT
NetworkManager-0.8.0-8.git20100426.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc13
Comment 8 Fedora Update System 2010-04-27 21:20:16 EDT
NetworkManager-0.8.0-8.git20100426.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc12
Comment 9 Fedora Update System 2010-04-30 19:49:37 EDT
NetworkManager-0.8.0-9.git20100429.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-9.git20100429.fc13
Comment 10 Fedora Update System 2010-05-04 02:12:40 EDT
NetworkManager-0.8.0-11.git20100503.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-11.git20100503.fc13
Comment 11 Fedora Update System 2010-05-04 02:14:32 EDT
NetworkManager-0.8.0-11.git20100503.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-11.git20100503.fc12
Comment 12 Fedora Update System 2010-05-04 19:50:11 EDT
NetworkManager-0.8.0-11.git20100503.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-05-05 05:15:42 EDT
NetworkManager-0.8.0-12.git20100504.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-12.git20100504.fc13
Comment 14 Fedora Update System 2010-05-05 05:18:26 EDT
NetworkManager-0.8.0-12.git20100504.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-12.git20100504.fc12
Comment 15 Fedora Update System 2010-05-06 03:01:43 EDT
NetworkManager-0.8.0-12.git20100504.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2010-05-11 02:54:24 EDT
NetworkManager-0.8.1-0.1.git20100510.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-0.1.git20100510.fc12
Comment 17 Fedora Update System 2010-06-10 15:06:01 EDT
NetworkManager-0.8.1-0.1.git20100510.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.