Bug 58527 - apxs puts LoadModule line in the wrong place
apxs puts LoadModule line in the wrong place
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-18 15:02 EST by vendor_bugs
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 06:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vendor_bugs 2002-01-18 15:02:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
apxs put the LoadModule line for my module after the last LoadModule line in the
httpd.conf file.

Unfortunately the result is that the LoadModule line for my module
is inside of a <IfDefine HAVE_PYTHON> ...</IfDefine> grouping.  Since I do not
have HAVE_PYTHON defined my module is never loaded.

To fix this I had to move the LoadModule out of the grouping
described above.  I also ran into BUG 55501 when I ran into this bug.

< <IfDefine HAVE_PYTHON>
< LoadModule python_module      modules/mod_python.so
< LoadModule dynamo_module      lib/apache/dynamoApache.so
< </IfDefine>

> <IfDefine HAVE_PYTHON>
> LoadModule python_module      modules/mod_python.so
> </IfDefine>
> LoadModule dynamo_module      modules/dynamoApache.so



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. apxs -i -a -n dynamo dynamoApache.so
2.
3.
	

Actual Results:  In httpd.conf:

<IfDefine HAVE_PYTHON>
LoadModule python_module      modules/mod_python.so
LoadModule dynamo_module      lib/apache/dynamoApache.so
</IfDefine>


Expected Results:  In httpd.conf:

<IfDefine HAVE_PYTHON>
LoadModule python_module      modules/mod_python.so
</IfDefine>
LoadModule dynamo_module      modules/dynamoApache.so



Additional info:

I ran into BUG 55501 also.
Comment 1 Joe Orton 2004-09-21 06:53:03 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

Note You need to log in before you can comment on or make changes to this bug.