Bug 585319 - Installer is assigning an incorrect /dev/sd_ drive letter to the first (and only) drive in the system.
Installer is assigning an incorrect /dev/sd_ drive letter to the first (and o...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 13:30 EDT by Ray Spartz
Modified: 2010-04-25 10:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-25 10:18:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/syslog file as requested (50.02 KB, application/octet-stream)
2010-04-23 14:09 EDT, Ray Spartz
no flags Details

  None (edit)
Description Ray Spartz 2010-04-23 13:30:46 EDT
Description of problem:
Drive is connected to SATA0 on the mobo, but RHEL Beta6 is assigning device name /dev/sde.  The device name should be /dev/sda.

Version-Release number of selected component (if applicable):


How reproducible:
Very, Attempted install 3 times and incorrect device name was assigned each time.

Steps to Reproduce:
1.  Boot Beta6 Gui Install
2.  Select Custom Disk layout
3.  Once initialized it will display the /dev/sd_ assigned
  
Actual results:
/dev/sde

Expected results:
/dev/sda

Additional info:
Drive is SATA, cabled to SATA0 on the mobo and shows as Drive 0 in the BIOS.  Install should assign this drive /dev/sda
Comment 1 Chris Lumens 2010-04-23 13:35:05 EDT
Device names are unstable and should not be counted on to be the same from reboot to reboot.  The kernel and other tools anaconda relies on are what set these names - not anaconda.  Please attach /tmp/syslog so I can verify that it's the kernel doing the name assignment.
Comment 3 Ray Spartz 2010-04-23 14:09:11 EDT
Created attachment 408697 [details]
/tmp/syslog file as requested

I am attaching /tmp/syslog per request.

I know the UUID is the 'new way' to refer to the devices, but so far every system I've loaded has started the HDD device names as sda, sdb, .. etc. and this was the first time I've seen otherwise.

Thank you,

Ray Spartz
Comment 4 RHEL Product and Program Management 2010-04-23 14:58:44 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Hans de Goede 2010-04-25 10:18:08 EDT
(In reply to comment #3)
> Created an attachment (id=408697) [details]
> /tmp/syslog file as requested
> 
> I am attaching /tmp/syslog per request.
> 
> I know the UUID is the 'new way' to refer to the devices, but so far every
> system I've loaded has started the HDD device names as sda, sdb, .. etc. and
> this was the first time I've seen otherwise.
> 

Looking at the syslog in question the HDD device names are starting with sda, as there actually is an SDA on the system. It just happens to get assigned to a usb mass storage disk (from a usb cardreader), rather then to the sata disk. But the system really has 5 scsi disks, and since probe order is not stable, the sata disk getting device node sde is perfectly fine.

Note You need to log in before you can comment on or make changes to this bug.