Bug 585391 - directory server deployment guide 8.1 typos and incorrect directions
directory server deployment guide 8.1 typos and incorrect directions
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.2.6
All Linux
low Severity low
: ---
: ---
Assigned To: Deon Ballard
ecs-bugs
:
Depends On:
Blocks: 249650
  Show dependency treegraph
 
Reported: 2010-04-23 16:57 EDT by Damon Tkoch
Modified: 2012-06-21 19:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 19:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damon Tkoch 2010-04-23 16:57:35 EDT
Description of problem:


Version-Release number of selected component (if applicable):
8.1


The Prefix section "1.2. Introduction to Directory Server" includes text:

Other LDAP clients, both third-party programs and custom programs written
using the LDAP client SDK, both the Mozilla LDAP SDK and the OpenLDAP SDK.

That sentence is not correct.  What about those clients?  Can we use them?  Are you just telling me they exist?


Additionally...
the directions in preface section "4. Giving Feedback" (page viii) are incorrect.  They say to:
• Select the Red Hat Directory Server product.
• Set the component to Doc - deployment-guide.
• Set the version number to 8.1.

There is no bugzilla product "Directory Server", just this product (389) which references directory server in its description.

The 389 product has no "Doc" component.

The 389 product only rises to version 7.1; there is no 8.1
Comment 1 Rich Megginson 2010-04-23 17:38:14 EDT
(In reply to comment #0)
> Description of problem:
> 
> 
> Version-Release number of selected component (if applicable):
> 8.1
> 
> 
> The Prefix section "1.2. Introduction to Directory Server" includes text:
> 
> Other LDAP clients, both third-party programs and custom programs written
> using the LDAP client SDK, both the Mozilla LDAP SDK and the OpenLDAP SDK.

> 
> That sentence is not correct.  What about those clients?  Can we use them?  Are
> you just telling me they exist?

I think the intention of these first two paragraphs is just to say that any LDAP client should work with the Red Hat Directory Server, no matter which client it is or which SDK it uses.

These paragraphs are awkwardly written - we should rewrite them.

> 
> 
> Additionally...
> the directions in preface section "4. Giving Feedback" (page viii) are
> incorrect.  They say to:
> • Select the Red Hat Directory Server product.
> • Set the component to Doc - deployment-guide.
> • Set the version number to 8.1.
> 
> There is no bugzilla product "Directory Server",

Do you mean "Red Hat Directory Server"?  Because you are correct, there is no product called "Directory Server", it's called "Red Hat Directory Server".

> just this product (389) which
> references directory server in its description.

Right.  This documentation is for the Red Hat Directory Server, which is not exactly the same as 389, but it is close enough for most practical purposes.

In addition, only Red Hat Directory Server customers can file bugs against Red Hat Directory Server.

> 
> The 389 product has no "Doc" component.

The only 389 specific docs are the man pages and the 389 wiki.  I guess we could add a category for man pages (there is already a category for wiki) but that wouldn't solve your problem.

So then, what is a 389 user supposed to do when confronted with a bug in the recommended Red Hat DS documentation?  Just file a bug against 389 -> Directory Server which is what you did.  We'll make sure it gets assigned appropriately.

> 
> The 389 product only rises to version 7.1; there is no 8.1    

http://port389.org/wiki/History
Comment 2 Damon Tkoch 2010-04-23 18:28:35 EDT
Thanks for the clarification!  I was not aware that bugzilla access to Red Hat Directory Server was only available to Red Hat Directory Server customers.  I appreciate your quick and clear response and the historical context.

If I find further points of confusion in the documentation I will continue to post them to 389 -> Directory
Server.

Thanks again,
-Damon
Comment 4 Deon Ballard 2010-05-06 16:59:16 EDT
I'll rewrite that intro paragraph as Rich noted in comment #1. 

As for the bug filing process, the docs correctly mention Red Hat Directory Server. I can't think of a way right now to not have the doc bugs use that product component, because these are not (technically) 389 Project documentation. Maybe the "unknown" component can be used?
Comment 5 Damon Tkoch 2010-05-06 21:42:41 EDT
Thanks.  I managed to post in more or less the right area in the end; I was confused by my lack of ability to post to the red hat directory server because I'm not yet a paying customer.  Maybe a note about that restriction or the ability to alternately post bugs to the 389 project?

But mostly that was a first-timers' mistake (my own, I mean) and the confusion is cleared up for me now.
Comment 6 Deon Ballard 2010-05-06 23:28:21 EDT
You're not the first one who's had that issue, Damon. :) I just haven't found a decent way around it in the RHDS docs. Maybe we should add a note to the wiki.
Comment 7 Deon Ballard 2010-06-14 10:25:03 EDT
I rewrote the paragraph to this...

*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~

Red Hat Directory Server is comprised of several components. The core of the directory itself is the server that implements the LDAP protocol. Red Hat Directory Server has a client-side graphical user interface on top of the LDAP server that allows end-users to search and change entries in the directory. Other LDAP clients, both third-party programs and custom programs written using the Mozilla LDAP SDK and the OpenLDAP SDK, can be used with Red Hat Directory Server or to integrate other applications with Red Hat Directory Server.

*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~

And it is live here:
http://www.redhat.com/docs/manuals/dir-server/8.1/deploy/Deployment_Guide-Introduction_to_Directory_Services-Introduction_to_DS.html

Changing status to modified.
Comment 8 Deon Ballard 2011-05-19 14:43:22 EDT
Changing modifieds to ON_QA.
Comment 10 Deon Ballard 2012-06-21 19:17:38 EDT
Closing.

Note You need to log in before you can comment on or make changes to this bug.