Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585501 - system-config-lvm cannot start due to missing module gnome
system-config-lvm cannot start due to missing module gnome
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-24 07:47 EDT by Steyn Huizinga
Modified: 2016-04-26 09:36 EDT (History)
8 users (show)

See Also:
Fixed In Version: system-config-lvm-1.1.12-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:42:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steyn Huizinga 2010-04-24 07:47:05 EDT
Description of problem:
system-config-lvm cannot start after installation. The module gnome cannot be found.


Version-Release number of selected component (if applicable):
system-config-lvm-1.1.11-1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install the system-config-lvm RPM
2. Run /usr/bin/system-config-lvm
3. A traceback is thrown. The module gnome is not found
  
Actual results:
[steyn@hzn9lnx003 ~]$ sudo yum install system-config-lvm
Loaded plugins: rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package system-config-lvm.noarch 0:1.1.11-1.el6 set to be updated
--> Processing Dependency: rhpl >= 0.148.2 for package: system-config-lvm-1.1.11-1.el6.noarch
--> Processing Dependency: usermode-gtk for package: system-config-lvm-1.1.11-1.el6.noarch
--> Processing Dependency: gnome-python2 for package: system-config-lvm-1.1.11-1.el6.noarch
--> Processing Dependency: urw-fonts for package: system-config-lvm-1.1.11-1.el6.noarch
--> Processing Dependency: pygtk2 for package: system-config-lvm-1.1.11-1.el6.noarch
--> Processing Dependency: pygtk2-libglade for package: system-config-lvm-1.1.11-1.el6.noarch
--> Processing Dependency: gnome-python2-canvas for package: system-config-lvm-1.1.11-1.el6.noarch
--> Running transaction check
---> Package gnome-python2.i686 0:2.28.0-2.el6 set to be updated
---> Package gnome-python2-canvas.i686 0:2.28.0-2.el6 set to be updated
--> Processing Dependency: libgnomecanvas >= 2.8.0 for package: gnome-python2-canvas-2.28.0-2.el6.i686
--> Processing Dependency: libgnomecanvas-2.so.0 for package: gnome-python2-canvas-2.28.0-2.el6.i686
---> Package pygtk2.i686 0:2.16.0-3.el6 set to be updated
--> Processing Dependency: pygobject2 for package: pygtk2-2.16.0-3.el6.i686
---> Package pygtk2-libglade.i686 0:2.16.0-3.el6 set to be updated
--> Processing Dependency: libglade-2.0.so.0 for package: pygtk2-libglade-2.16.0-3.el6.i686
---> Package rhpl.i686 0:0.221-2 set to be updated
---> Package urw-fonts.noarch 0:2.4-9.1.el6 set to be updated
---> Package usermode-gtk.i686 0:1.102-1.el6 set to be updated
--> Running transaction check
---> Package libglade2.i686 0:2.6.4-3.1.el6 set to be updated
--> Processing Dependency: xml-common for package: libglade2-2.6.4-3.1.el6.i686
---> Package libgnomecanvas.i686 0:2.26.0-2.1.el6 set to be updated
---> Package pygobject2.i686 0:2.20.0-4.el6 set to be updated
--> Running transaction check
---> Package xml-common.noarch 0:0.6.3-31.el6 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================================================================================================
 Package                                                          Arch                                               Version                                                     Repository                                             Size
=============================================================================================================================================================================================================================================
Installing:
 system-config-lvm                                                noarch                                             1.1.11-1.el6                                                rhel-beta                                             470 k
Installing for dependencies:
 gnome-python2                                                    i686                                               2.28.0-2.el6                                                rhel-beta                                              45 k
 gnome-python2-canvas                                             i686                                               2.28.0-2.el6                                                rhel-beta                                              30 k
 libglade2                                                        i686                                               2.6.4-3.1.el6                                               rhel-beta                                              60 k
 libgnomecanvas                                                   i686                                               2.26.0-2.1.el6                                              rhel-beta                                             205 k
 pygobject2                                                       i686                                               2.20.0-4.el6                                                rhel-beta                                             162 k
 pygtk2                                                           i686                                               2.16.0-3.el6                                                rhel-beta                                             925 k
 pygtk2-libglade                                                  i686                                               2.16.0-3.el6                                                rhel-beta                                              22 k
 rhpl                                                             i686                                               0.221-2                                                     rhel-beta                                             211 k
 urw-fonts                                                        noarch                                             2.4-9.1.el6                                                 rhel-beta                                             3.1 M
 usermode-gtk                                                     i686                                               1.102-1.el6                                                 rhel-beta                                              98 k
 xml-common                                                       noarch                                             0.6.3-31.el6                                                rhel-beta                                             9.3 k

Transaction Summary
=============================================================================================================================================================================================================================================
Install      12 Package(s)
Upgrade       0 Package(s)

Total download size: 5.2 M
Installed size: 14 M
Is this ok [y/N]: y
Downloading Packages:
(1/12): gnome-python2-2.28.0-2.el6.i686.rpm                                                                                                                                                                           |  45 kB     00:00     
(2/12): gnome-python2-canvas-2.28.0-2.el6.i686.rpm                                                                                                                                                                    |  30 kB     00:00     
(3/12): libglade2-2.6.4-3.1.el6.i686.rpm                                                                                                                                                                              |  60 kB     00:01     
(4/12): libgnomecanvas-2.26.0-2.1.el6.i686.rpm                                                                                                                                                                        | 205 kB     00:01     
(5/12): pygobject2-2.20.0-4.el6.i686.rpm                                                                                                                                                                              | 162 kB     00:01     
(6/12): pygtk2-2.16.0-3.el6.i686.rpm                                                                                                                                                                                  | 925 kB     00:05     
(7/12): pygtk2-libglade-2.16.0-3.el6.i686.rpm                                                                                                                                                                         |  22 kB     00:00     
(8/12): rhpl-0.221-2.i686.rpm                                                                                                                                                                                         | 211 kB     00:01     
(9/12): system-config-lvm-1.1.11-1.el6.noarch.rpm                                                                                                                                                                     | 470 kB     00:02     
(10/12): urw-fonts-2.4-9.1.el6.noarch.rpm                                                                                                                                                                             | 3.1 MB     00:11     
(11/12): usermode-gtk-1.102-1.el6.i686.rpm                                                                                                                                                                            |  98 kB     00:01     
(12/12): xml-common-0.6.3-31.el6.noarch.rpm                                                                                                                                                                           | 9.3 kB     00:00     
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                        121 kB/s | 5.2 MB     00:44     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : pygobject2-2.20.0-4.el6.i686                                                                                                                                                                                         1/12 
  Installing     : pygtk2-2.16.0-3.el6.i686                                                                                                                                                                                             2/12 
  Installing     : usermode-gtk-1.102-1.el6.i686                                                                                                                                                                                        3/12 
  Installing     : rhpl-0.221-2.i686                                                                                                                                                                                                    4/12 
  Installing     : gnome-python2-2.28.0-2.el6.i686                                                                                                                                                                                      5/12 
  Installing     : xml-common-0.6.3-31.el6.noarch                                                                                                                                                                                       6/12 
  Installing     : urw-fonts-2.4-9.1.el6.noarch                                                                                                                                                                                         7/12 
  Installing     : libglade2-2.6.4-3.1.el6.i686                                                                                                                                                                                         8/12 
  Installing     : libgnomecanvas-2.26.0-2.1.el6.i686                                                                                                                                                                                   9/12 
  Installing     : gnome-python2-canvas-2.28.0-2.el6.i686                                                                                                                                                                              10/12 
  Installing     : pygtk2-libglade-2.16.0-3.el6.i686                                                                                                                                                                                   11/12 
  Installing     : system-config-lvm-1.1.11-1.el6.noarch                                                                                                                                                                               12/12 

Installed:
  system-config-lvm.noarch 0:1.1.11-1.el6                                                                                                                                                                                                    

Dependency Installed:
  gnome-python2.i686 0:2.28.0-2.el6        gnome-python2-canvas.i686 0:2.28.0-2.el6      libglade2.i686 0:2.6.4-3.1.el6      libgnomecanvas.i686 0:2.26.0-2.1.el6      pygobject2.i686 0:2.20.0-4.el6        pygtk2.i686 0:2.16.0-3.el6     
  pygtk2-libglade.i686 0:2.16.0-3.el6      rhpl.i686 0:0.221-2                           urw-fonts.noarch 0:2.4-9.1.el6      usermode-gtk.i686 0:1.102-1.el6           xml-common.noarch 0:0.6.3-31.el6     

Complete!


[steyn@hzn9lnx003 ~]$ system-config-lvm 
Traceback (most recent call last):
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 50, in <module>
    from Volume_Tab_View import Volume_Tab_View
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 11, in <module>
    from Properties_Renderer import Properties_Renderer
  File "/usr/share/system-config-lvm/Properties_Renderer.py", line 33, in <module>
    import gnome
ImportError: No module named gnome



Expected results:
Successful start of system-config-lvm


Additional info:
gnome-python2-2.28.0-2.el6.i686 is installed
Comment 2 RHEL Product and Program Management 2010-04-24 09:12:08 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Marek Grac 2010-04-28 11:35:39 EDT
Dependencies to be added:
* gnome-python2-bonobo
* gnome-python2-gnome
Comment 4 Brian Brock 2010-04-30 15:17:31 EDT
Simple to test, setting qa_ack
Comment 6 Alexander Todorov 2010-08-23 08:30:36 EDT
# rpm -q system-config-lvm
system-config-lvm-1.1.12-7.el6.noarch

# rpm -qR system-config-lvm | grep gnome
gnome-python2  
gnome-python2-bonobo  
gnome-python2-canvas  
gnome-python2-gnome
Comment 7 releng-rhel@redhat.com 2010-11-10 16:42:49 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.