Bug 585513 - [abrt] crash in mozplugger-1.12.1-7.fc12: Process /usr/bin/mozplugger-helper was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in mozplugger-1.12.1-7.fc12: Process /usr/bin/mozplugger-helper ...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mozplugger (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f9c0965400322fde24a6cb51246...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-24 13:28 UTC by Christophe Dumez
Modified: 2010-09-29 12:18 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-29 12:18:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (5.48 KB, text/plain)
2010-04-24 13:28 UTC, Christophe Dumez
no flags Details

Description Christophe Dumez 2010-04-24 13:28:02 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: mozplugger-helper 0,1,10,0,0,0,0,0 'play \"$file\"'
component: mozplugger
executable: /usr/bin/mozplugger-helper
global_uuid: f9c0965400322fde24a6cb512464f2b662a46e0a
kernel: 2.6.33.2-41.fc13.x86_64
package: mozplugger-1.12.1-7.fc12
rating: 4
reason: Process /usr/bin/mozplugger-helper was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. I think it happened when I played an audio file in firefox
2.
3.

Comment 1 Christophe Dumez 2010-04-24 13:28:04 UTC
Created attachment 408828 [details]
File: backtrace

Comment 2 Paul Lazaga 2010-05-09 02:10:34 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Facebook page in Mozilla Firefox
2. Any incoming chat message generates error
3.


Comment
-----
Chat using facebook through firefox.  Any incoming message generates error... with each message

Comment 3 Alexander Dutton 2010-05-10 10:11:15 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Head to Facebook
2. Get someone to message you using Facebook Chat
3. See Totem appear to play "pop.mp3"
4. Close Totem immediately


Comment
-----
Presumably something's gone a little wrong for the alert sound (pop.mp3) (when someone initiates an FB chat session) to open in a new Totem window. I have no idea why this happening (or me subsequently closing Totem) might cause mozplugger-helper to segfault.

Comment 4 Paolo Leoni 2010-05-12 19:23:08 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Open firefox
2. Login to facebook
3. wait for a chat contact...


Comment
-----
when I receive a message in facebook chat, sometimes mozplugger crash.

Comment 5 Peter Hanecak 2010-05-24 19:24:35 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Facebook or Youtube


Comment
-----
I've got Facebok in one window, Youtube in second.

Wait a second, clarification: Youtube is not closed but same crash occured again.

The suspect might by some Flash stuff posted by Radio_FM.

Browser did not crashed.

Comment 6 Tim McConnell 2010-05-26 06:46:29 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


Comment
-----
Not sure what caused the crash, I was playing an online game when the crash report popped up

Comment 7 Tim McConnell 2010-05-28 06:51:22 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


Comment
-----
Facebook page caused it

Comment 8 Tim McConnell 2010-05-29 17:10:43 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


Comment
-----
Facebook chat

Comment 9 Tim McConnell 2010-06-01 15:19:59 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


Comment
-----
Facebook chat

Comment 10 Tim McConnell 2010-06-02 22:46:10 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. go to facebook
2.Have someone try to chat with you 
3. Get ABRT pop up 


Comment
-----
Don't know

Comment 11 Tim McConnell 2010-06-03 05:48:04 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. go to facebook
2.Have someone try to chat with you 
3. Get ABRT pop up 


Comment
-----
Don't know

Comment 12 Tim McConnell 2010-06-04 06:14:39 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. go to facebook
2.Have someone try to chat with you 
3. Get ABRT pop up 


Comment
-----
Don't know what I did.

Comment 13 Tim McConnell 2010-06-04 20:58:57 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. go to facebook
2.Have someone try to chat with you 
3. Get ABRT pop up

Comment 14 Tim McConnell 2010-06-04 21:53:35 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. go to facebook
2.Have someone try to chat with you 
3. Get ABRT pop up

Comment 15 Tim McConnell 2010-06-04 22:40:14 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. go to facebook
2.Have someone try to chat with you 
3. Get ABRT pop up 


Comment
-----
These errors from the chat window poping up shouldn't cause a segfault in Mozplugger:
Error: [Exception... "update.locale file doesn't exist in either the XCurProcD or GreD directories"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js :: getLocale :: line 549"  data: no]
Source File: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js
Line: 549

Error: [Exception... "update.locale file doesn't exist in either the XCurProcD or GreD directories"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js :: getLocale :: line 549"  data: no]
Source File: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js
Line: 549
Please fix it

Comment 16 Tim McConnell 2010-06-05 20:05:55 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. go to facebook
2.Have someone try to chat with you 
3. Get ABRT pop up 


Comment
-----
These errors from the chat window poping up shouldn't cause a segfault in Mozplugger:
Error: [Exception... "update.locale file doesn't exist in either the XCurProcD or GreD directories"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js :: getLocale :: line 549"  data: no]
Source File: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js
Line: 549

Error: [Exception... "update.locale file doesn't exist in either the XCurProcD or GreD directories"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js :: getLocale :: line 549"  data: no]
Source File: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js
Line: 549
Please fix it

Comment 17 Tim McConnell 2010-06-09 23:05:44 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. go to facebook
2.Have someone try to chat with you 
3. Get ABRT pop up 


Comment
-----
These errors from the chat window poping up shouldn't cause a segfault in Mozplugger:
Error: [Exception... "update.locale file doesn't exist in either the XCurProcD or GreD directories"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js :: getLocale :: line 549"  data: no]
Source File: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js
Line: 549

Error: [Exception... "update.locale file doesn't exist in either the XCurProcD or GreD directories"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js :: getLocale :: line 549"  data: no]
Source File: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js
Line: 549
Please fix it

Comment 18 Tim McConnell 2010-06-10 22:12:26 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. go to facebook
2.Have someone try to chat with you 
3. Get ABRT pop up 


Comment
-----
These errors from the chat window poping up shouldn't cause a segfault in Mozplugger:
Error: [Exception... "update.locale file doesn't exist in either the XCurProcD or GreD directories"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js :: getLocale :: line 549"  data: no]
Source File: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js
Line: 549

Error: [Exception... "update.locale file doesn't exist in either the XCurProcD or GreD directories"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js :: getLocale :: line 549"  data: no]
Source File: file:///usr/lib/xulrunner-1.9.1/components/nsUpdateService.js
Line: 549
Please fix it

Comment 19 Pavel Roskin 2010-06-21 18:46:21 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Install 64-bit Flash plugin (put libflashplayer.so to .mozilla/plugins/)
2. Disable Flash in Firefox (Tools->Addons->Plugins->Shockwave Flash)
3. Open vkontakte.ru in Firefox (you may need to register)


Comment
-----
I don't know the exact reason.  I'll try reenabling Flash and visiting other sites. Recent changes to my system also include updating the system and installing x264 and h264enc.  I also run a non-distribution kernel (wireless-testing.git), which I also updated today.

Comment 20 Pavel Roskin 2010-06-21 19:15:52 UTC
Indeed, enabling Flash fixes the crash.  I think it's because Flash is the first choice for some media and mozplugger is the second.  Then I enabled Flash and disabled mozplugger, and I don't get crashes either.

Comment 21 bugzilla 2010-06-23 18:01:22 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


Comment
-----
I don't know what caused the bug, and it did not seem to affect anything. I received a Facebook message at around the same time, so perhaps that is related.

Comment 22 Todd Savoie 2010-07-05 09:27:02 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Opening a PDF in mozilla
2.
3.

Comment 23 terrmit 2010-07-28 05:53:25 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. if I open page http://boloba.net/84-le-plugin-boutique-evolue.html in Mozilla Firefox
2. or http://www.guppyland.org/www/blog.php?lng=fr&sel=pg&pg=149
3.

Comment 24 bugzilla 2010-07-29 23:42:28 UTC
Package: mozplugger-1.12.1-7.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


Comment
-----
I was working in oowriter.

Comment 25 Ngo Than 2010-09-29 12:18:30 UTC
it should be fixed in mozplugger-1.14.2-1.fc13 which will be available in f13-update-testing soon. Or you can download it from http://koji.fedoraproject.org/koji/buildinfo?buildID=189076


Note You need to log in before you can comment on or make changes to this bug.