Bug 585542 - Xorg Intel Driver doesn't work
Summary: Xorg Intel Driver doesn't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-24 16:38 UTC by Gordan Bobic
Modified: 2011-12-16 18:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-16 18:28:34 UTC
Target Upstream Version:


Attachments (Terms of Use)
output lspci (1.95 KB, text/plain)
2010-07-20 10:20 UTC, Arjan van Lent
no flags Details
output dmesg (77.27 KB, text/plain)
2010-07-20 10:21 UTC, Arjan van Lent
no flags Details
messages (380.10 KB, text/plain)
2010-07-20 10:22 UTC, Arjan van Lent
no flags Details

Description Gordan Bobic 2010-04-24 16:38:48 UTC
Description of problem:
Xorg fails to work with the provided Intel driver. X loads up the point where there is a mouse pointer on the screen, then stops.

Tested on Dell Mini 1012, but most likely applies to other Atom N450 machines as well.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.10.0-4el6.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Either remove xorg.conf or set the driver in it to "intel"
2. startx
  
Actual results:
X locks up before it finishes loading.

Expected results:
Normal X operation.

Additional info:
Xorg.0.log ends in a large number of the following messages:
(EE) intel(0): Failed to submit batch buffer, expect rendering corruption or even a frozen display: Input/output error.

Fedora 12 works perfectly on the exact same hardware. The driver on Fedora 12 is:
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64

Installing Fedora 12 driver onto RHEL6b doesn't cure the problem, in fact it makes it worse - it crashes the display completely. This leads me to think that the problem may be related to the Intel GPU kernel driver.

RHEL6b kernel: 2.6.32-19.el6.x86_64
Fedora 12 kernel: 2.6.32.11-99.fc12.x86_64

I installed the F12 kernel on RHEL6b, and that cures the problem - X now starts fine, with the following two F12 packages installed:

xorg-x11-drv-intel-2.9.1-1.fc12.x86_64
kernel-2.6.32.11-99.fc12.x86_64

Once I got this working I updated the xorg-x11-drv-intel back to RHEL6b version (xorg-x11-drv-intel-2.10.0-4el6.x86_64) and this also now works, when F12 kernel is used. When the system is booted with the RHEL6b kernel-2.6.32-19.el6.x86_64, it breaks.

This fairly conclusively pins the problem down to the kernel.

Comment 2 RHEL Program Management 2010-04-24 18:12:58 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Matěj Cepl 2010-05-06 13:56:26 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach

* output of the dmesg command,
* system log (/var/log/messages), and
* X server log file (/var/log/Xorg.*.log)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 4 Gordan Bobic 2010-05-06 14:04:21 UTC
Unfortunately, I don't have access to the machine I tested this on any more. However, the symptoms look very similar to bug 523646. It could be related.

Comment 5 Matěj Cepl 2010-05-06 14:33:58 UTC
(In reply to comment #4)
> Unfortunately, I don't have access to the machine I tested this on any more.
> However, the symptoms look very similar to bug 523646. It could be related.    

This isn't bug 528312 (which is what was bug 523646 closed as duplicate of) ... that one is long freeze (couple of seconds) when resuming from suspend, but then after some delay it works as usual. This bug (if I am not mistaken) makes computer completely broken. Am I right?

Comment 7 Gordan Bobic 2010-05-06 14:50:36 UTC
This issue makes the machine completely unusable at least from the console. It breaks both the graphical installer (unless the basic driver option is used), and the normal X operation after installation is complete.

I hadn't checked if the machine still ends up responding to network logins.

Comment 8 RHEL Program Management 2010-07-15 14:40:30 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 9 Gordan Bobic 2010-07-15 14:52:40 UTC
Has anyone (other than me) actually tested the installer on an Atom N450 based machine such as the Dell Mini 1012?

It will be at least a few weeks before I have access to another N450 based machine to re-test with the latest beta, but if the release ends up not working, that would make RHEL6 unusable on most if not all new netbooks. If this issue is specific to the Dell Mini 1012, I guess that isn't a big deal, but if it applies to all N450 machines, it's pretty serious.

Then again, it is plausible that a change that made it into 6b2 already provides a (heisen)fix.

Comment 10 Arjan van Lent 2010-07-20 10:20:24 UTC
Created attachment 433119 [details]
output lspci

hardware profile

Comment 11 Arjan van Lent 2010-07-20 10:21:35 UTC
Created attachment 433120 [details]
output dmesg

Comment 12 Arjan van Lent 2010-07-20 10:22:45 UTC
Created attachment 433121 [details]
messages

Comment 13 Arjan van Lent 2010-07-20 10:25:20 UTC
same problem here, only for me it ends up with a blank screen wo pointer and the system totally hangs so only hard reset works.

Don't seem to have a Xorg logfile.

Comment 15 RHEL Program Management 2011-01-07 04:27:54 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 16 Suzanne Yeghiayan 2011-01-07 16:08:56 UTC
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.

Comment 17 RHEL Program Management 2011-02-01 05:57:29 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 18 RHEL Program Management 2011-02-01 18:17:48 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 19 RHEL Program Management 2011-04-04 02:28:35 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 20 RHEL Program Management 2011-10-07 14:59:34 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 21 Adam Jackson 2011-12-16 18:28:34 UTC
Try RHEL 6.2.


Note You need to log in before you can comment on or make changes to this bug.