Bug 585605 - [abrt] crash in glx-utils-7.7-4.fc12: Process /usr/bin/glxgears was killed by signal 11 (SIGSEGV)
[abrt] crash in glx-utils-7.7-4.fc12: Process /usr/bin/glxgears was killed by...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:54d633f9d770024799751c5785c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-24 21:40 EDT by RedHat-User
Modified: 2010-08-03 23:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 23:00:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (7.79 KB, text/plain)
2010-04-24 21:40 EDT, RedHat-User
no flags Details

  None (edit)
Description RedHat-User 2010-04-24 21:40:00 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: glxgears
component: mesa
executable: /usr/bin/glxgears
global_uuid: 54d633f9d770024799751c5785c895b3d6b20619
kernel: 2.6.32.11-99.fc12.x86_64
package: glx-utils-7.7-4.fc12
rating: 4
reason: Process /usr/bin/glxgears was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

comment
-----
I have an x86_64 CentOS 5 machine running VirtualBox 3.16.  The machine has an ATI Radeon HD 2600XT and I use the proprietary drivers.  Glxgears works fine on it (the host).

I have Fedora 12 (x86_64) installed as a VirturalBox guest.  The VirtualBox guest additions are installed, which should provide 3D acceleration support.  When I execute glxgears in the Fedora 12 guest, it crashes.

How to reproduce
-----
1.  Execute the glxgears command from a konsole.
2.
3.
Comment 1 RedHat-User 2010-04-24 21:40:02 EDT
Created attachment 408906 [details]
File: backtrace
Comment 2 Owen Taylor 2010-07-14 12:44:42 EDT
vboxvideo bug, not Mesa bug

Same as bug 603569, http://www.virtualbox.org/ticket/7061
Comment 3 RedHat-User 2010-08-03 23:00:13 EDT
Closing this ticket since this appears to be an issue with VirtualBox instead of Fedora.  In  Noel Duffy's VirtualBox bug ticket, <http://www.virtualbox.org/ticket/7061>, the user "galalleni" wrote, "Same issue here. It appears that the system is using Mesa's libGL (which is v7.8) instead of the libGL Vbox uses (v7.2) - that's why this error is occurring."

I'm going to look over there to see if there is a way to make VirtualBox use the same Mesa libGL.

Note You need to log in before you can comment on or make changes to this bug.