Bug 585620 - UnicodeDecodeError from yum
UnicodeDecodeError from yum
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-25 01:16 EDT by Mattias Ellert
Modified: 2014-01-21 18:14 EST (History)
9 users (show)

See Also:
Fixed In Version: PackageKit-0.6.4-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-25 17:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2010-04-25 01:16:01 EDT
Description of problem:
I got a popup window saying that an internal system error has occurred. The details are copied below:

Error Type: <type 'exceptions.UnicodeDecodeError'>
Error Value: 'ascii' codec can't decode byte 0xc3 in position 144: ordinal not in range(128)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3238, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3234, in main
    backend = PackageKitYumBackend('', lock=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 238, in __init__
    self.doLock()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 344, in doLock
    self.error(ERROR_CANNOT_GET_LOCK, "Yum is locked by another application. $s" $ msg)
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 135, in error
    print "error\t$s\t$s" $ (err, description)
  File : /usr/lib64/python2.6/codecs.py, line 351, in write
    data, consumed = self.encode(object, self.errors)

Version-Release number of selected component (if applicable):
yum-3.2.27-3.fc13.noarch

Steps to Reproduce:
This happened while I was doing a "yum groupinstall", but that process went on fine. I suspect this message is from some process running in the background, like the check for updates check, that failed due to yum being busy.

Additional info:
I am running in a Swedish locale
Comment 1 Richard Hughes 2010-04-25 17:04:28 EDT
commit 90c0aee993691e698d414cbf450284dd8f8db0ab
Author: Richard Hughes <richard@hughsie.com>
Date:   Sun Apr 25 22:03:58 2010 +0100

    yum: Ensure the lock failure message is proper unicode. Fixes rh#585620

:100755 100755 67111a2... 3891589... M  backends/yum/yumBackend.py
Comment 2 Fedora Update System 2010-05-06 06:16:01 EDT
PackageKit-0.6.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/PackageKit-0.6.4-1.fc13
Comment 3 Fedora Update System 2010-05-24 15:42:38 EDT
PackageKit-0.6.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.