Bug 585728 - keyboard/mouse input not accepted in graphical anaconda
keyboard/mouse input not accepted in graphical anaconda
Status: CLOSED DUPLICATE of bug 585621
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-25 15:39 EDT by Alexander Boström
Modified: 2010-04-29 12:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 12:50:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/X.log from a failed anaconda run (20.79 KB, text/plain)
2010-04-29 10:27 EDT, Andy Lutomirski
no flags Details

  None (edit)
Description Alexander Boström 2010-04-25 15:39:56 EDT
Description of problem:
When Anaconda switches to graphical mode the keyboard stops working and the mouse pointer won't move either.

Version-Release number of selected component (if applicable):
anaconda 13.38

How reproducible:
Always.

Steps to Reproduce:
1. Boot into the installer (I used preupgrade, booting from /boot/upgrade but removed the kickstart argument)
2. Choose language and keyboard (English, sv-latin1)
  
Additional info:
Keyboard is PS/2, mouse is USB.

Is this "bug 553780 - keyboard/mouse input not accepted in stage2" again?
Comment 1 Hans de Goede 2010-04-26 04:42:02 EDT
(In reply to comment #0)
> Description of problem:
> When Anaconda switches to graphical mode the keyboard stops working and the
> mouse pointer won't move either.
> 
> Version-Release number of selected component (if applicable):
> anaconda 13.38
> 
> How reproducible:
> Always.
> 
> Steps to Reproduce:
> 1. Boot into the installer (I used preupgrade, booting from /boot/upgrade but
> removed the kickstart argument)
> 2. Choose language and keyboard (English, sv-latin1)
> 
> Additional info:
> Keyboard is PS/2, mouse is USB.
> 
> Is this "bug 553780 - keyboard/mouse input not accepted in stage2" again?    

Could be, but then I would expect a lot more similar reports, I think this is xorg / the kernel locking up. Moving over to xorg.
Comment 2 Alexander Boström 2010-04-26 18:02:50 EDT
Maybe, but not completely. I forgot to mention: With the right kickstart config it shows a text entry box with a still blinking cursor, so it's still alive.

I'll try to figure out a way to debug this.
Comment 3 Andy Lutomirski 2010-04-29 10:26:25 EDT
I have the same problem.  It's not a crash.  Here's how I debugged it:

1. Boot with nokill.  Makes life a *lot* easier.
2. Wait for the install to "hang."  This is 100% reliable.
3. Alt+SysRQ+r
4. Ctrl-Alt-F2

OK, now we're in business.  dmesg shows no errors at all.

Looking at /tmp/X.log, I see lots of "(EE) No input driver/identifier specified (ignoring)"

I think that there are two problems with the preupgrade image:

1. /etc/X11/xorg.conf.d/10-evdev.conf is missing.  That file is importable.
2. Note the above path.  /etc/xorg.conf.d should be /etc/X11/xorg.conf.d

Fixing both of those from the console causes Xorg to work (although it's too late for anaconda at that point).
Comment 4 Andy Lutomirski 2010-04-29 10:27:40 EDT
Created attachment 410124 [details]
/tmp/X.log from a failed anaconda run

This is X.log pulled after forcibly switching the VT.
Comment 5 Hans de Goede 2010-04-29 12:50:45 EDT
Thanks for the ping (by mail), you're right this is not an X-server issue but a bad interaction between the X server and anaconda, which has been fixed now.

*** This bug has been marked as a duplicate of bug 585621 ***

Note You need to log in before you can comment on or make changes to this bug.