Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585755 - yum update hangs by updating hpijs.
yum update hangs by updating hpijs.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-25 18:56 EDT by sjoerd
Modified: 2010-06-16 23:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 23:06:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sjoerd 2010-04-25 18:56:26 EDT
Description of problem:
Yum updating hpijs hangs on running hpcups-update-ppds

28437 pts/0    S+     0:00 /bin/bash /usr/bin/hpcups-update-ppds
28441 pts/0    S+     0:00 lpstat -h /var/run/cups/cups.sock -p Cups-PDF

Last excerpt from yum update:
......
Updating: 1:nfs-utils-1.2.1-5.fc12.x86_64    18/50 
Updating: hplip-common-3.10.2-6.fc12.x86_64  19/50 
Updating: hplip-libs-3.10.2-6.fc12.x86_64    20/50 
Updating: libsane-hpaio-3.10.2-6.fc12.x86_64 21/50 
Updating: 1:hpijs-3.10.2-6.fc12.x86_64       22/50
_hangs_

Version-Release number of selected component (if applicable):
hpijs-3.10.2.6.fc12.x86_64

How reproducible:
Dunno. Still hangs after 2 hours of this writing.

Steps to Reproduce:
1. yum update hpijs?
2.
3.
  
Actual results:
hpijs gets installed

Expected results:


Additional info:
# cat /var/tmp/rpm-tmp.YwrQT7
/usr/bin/hpcups-update-ppds &>/dev/null ||:

# uname -r
2.6.32.11-105.fc12.x86_64

# rpm -qa *PyQt*
PyQt4-4.7.3-1.fc12.x86_64
PyQt-3.18.1-6.fc12.x86_64
Comment 1 sjoerd 2010-04-25 19:07:19 EDT
Oops:

Actual results:
hpijs install hangs forever

Expected results:
hpijs gets installed
Comment 2 sjoerd 2010-04-25 20:19:44 EDT
Update:

killing the avahi-daemon process, witch went 100% cpu, solves this hang and yum update finally updates all the latest packages.

Updated:
  ModemManager.x86_64 0:0.3-9.git20100409.fc12          NetworkManager.x86_64 1:0.8.0-6.git20100408.fc12      
  NetworkManager-glib.x86_64 1:0.8.0-6.git20100408.fc12 NetworkManager-gnome.x86_64 1:0.8.0-6.git20100408.fc12
  abrt.x86_64 0:1.0.9-1.fc12                            abrt-addon-ccpp.x86_64 0:1.0.9-1.fc12                 
  abrt-addon-kerneloops.x86_64 0:1.0.9-1.fc12           abrt-addon-python.x86_64 0:1.0.9-1.fc12               
  abrt-desktop.x86_64 0:1.0.9-1.fc12                    abrt-gui.x86_64 0:1.0.9-1.fc12                        
  abrt-libs.x86_64 0:1.0.9-1.fc12                       abrt-plugin-bugzilla.x86_64 0:1.0.9-1.fc12            
  abrt-plugin-logger.x86_64 0:1.0.9-1.fc12              abrt-plugin-runapp.x86_64 0:1.0.9-1.fc12              
  hpijs.x86_64 1:3.10.2-6.fc12                          hplip.x86_64 0:3.10.2-6.fc12                          
  hplip-common.x86_64 0:3.10.2-6.fc12                   hplip-gui.x86_64 0:3.10.2-6.fc12                      
  hplip-libs.x86_64 0:3.10.2-6.fc12                     libgudev1.x86_64 0:145-20.fc12                        
  libsane-hpaio.x86_64 0:3.10.2-6.fc12                  libudev.x86_64 0:145-20.fc12                          
  nfs-utils.x86_64 1:1.2.1-5.fc12                       udev.x86_64 0:145-20.fc12                             
  xorg-x11-drv-wacom.x86_64 0:0.10.5-1.fc12            

Complete!
Comment 3 Tim Waugh 2010-04-26 04:07:23 EDT
That's weird.

Can you find any logged messages in /var/log/messages about why avahi-daemon was so busy?  Or cupsd, for that matter?

hpcups-update-ppds calls lpstat, which sends a request to cupsd and waits for a response.  It looks like we just didn't get a response for ages.  But cupsd itself doesn't talk to avahi, only the dnssd backend does -- and there's no reason that should even have been running.  So avahi-daemon being at 100% CPU doesn't really explain enough about what went wrong. :-(
Comment 4 sjoerd 2010-04-26 14:51:10 EDT
I don't have much more info. Some lines from /var/log/messages:

Apr 26 02:12:28 asus avahi-dnsconfd[16293]: read(): EOF
Apr 26 02:12:35 asus yum: Updated: 1:hpijs-3.10.2-6.fc12.x86_64
Apr 26 02:12:40 asus yum: Updated: hplip-3.10.2-6.fc12.x86_64
Apr 26 02:12:47 asus ntpd[14103]: Deleting interface #10 pan0:avahi, 169.254.8.153#123, interface stats: receiv
ed=0, sent=0, dropped=0, active_time=159058 secs

I could'n simply stop the avahi-daemon in the normal manner by entering *service avahi-daemon stop* this command didn't work due to a timeout.

I had to kill the daemon with the *kill -9 <pid>* command to shut it down hence the last ntpd line in the log.

Maybe it isn't an hpijs bug but aan avahi bug. I don't no.

Btw. There wasn't any more info in the cups logs.

Note You need to log in before you can comment on or make changes to this bug.