Bug 585855 - error in man page of dhclient.conf
Summary: error in man page of dhclient.conf
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcp   
(Show other bugs)
Version: 5.7
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: Jiri Popelka
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-26 09:10 UTC by Greg Matthews
Modified: 2011-07-21 09:03 UTC (History)
4 users (show)

Fixed In Version: dhcp-3.0.5-27.el5
Doc Type: Bug Fix
Doc Text:
There was a small error regarding the dhcp-lease-time option in the dhclient.conf(5) man page. With this update, the man page has been amended.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 09:03:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1038 normal SHIPPED_LIVE dhcp bug fix and enhancement update 2011-07-20 15:43:54 UTC

Description Greg Matthews 2010-04-26 09:10:00 UTC
Description of problem:
There is a small error in the "Lease Requirements and Requests" section of the man page for dhclient.conf(5). The line:
"...the client can specify a requested-lease-time option..."

should read something like:
"...the client can specify a requested dhcp-lease-time option..."

Version-Release number of selected component (if applicable):
dhclient-3.0.5-21.el5_4.1.i386


How reproducible:
always

Steps to Reproduce:
1. man dhclient.conf
2.
3.
  
Actual results:


Expected results:


Additional info:

proposed patch to the troff file:

--- dhclient.conf.5.old 2010-04-26 09:49:41.000000000 +0100
+++ dhclient.conf.5.new 2010-04-26 09:51:14.000000000 +0100
@@ -217,7 +217,7 @@
 the server with the specified values.  These are full option
 declarations as described in \fBdhcp-options(5)\fR.  Options that are
 always sent in the DHCP protocol should not be specified here, except
-that the client can specify a \fBrequested-lease-time\fR option other
+that the client can specify a requested \fBdhcp-lease-time\fR option other
 than the default requested lease time, which is two hours.  The other
 obvious use for this statement is to send information to the server
 that will allow it to differentiate between this client and other

Comment 2 RHEL Product and Program Management 2010-08-09 18:24:51 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 3 RHEL Product and Program Management 2011-01-11 20:35:22 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Product and Program Management 2011-01-11 22:28:08 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 8 Alexander Todorov 2011-05-09 09:13:43 UTC
dhclient-3.0.5-29.el5

LEASE REQUIREMENTS AND REQUESTS now reads

.... the client can specify a
       requested dhcp-lease-time option other than the default requested lease time, which is two hours.

Comment 9 Tomas Capek 2011-05-31 08:19:34 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
There was a small error regarding the dhcp-lease-time option in the dhclient.conf(5) man page. With this update, the man page has been amended.

Comment 10 errata-xmlrpc 2011-07-21 09:03:57 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1038.html


Note You need to log in before you can comment on or make changes to this bug.