Bug 585884 - [abrt] crash in python-twisted-core-8.2.0-3.fc12: fedora.py:46:get_timezone:AttributeError: 'NoneType' object has no attribute 'groupdict'
[abrt] crash in python-twisted-core-8.2.0-3.fc12: fedora.py:46:get_timezone:A...
Status: CLOSED DUPLICATE of bug 544986
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
abrt_hash:b8058310
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 06:28 EDT by Norfaisal Ismail
Modified: 2015-02-01 17:51 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 06:42:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.64 KB, text/plain)
2010-04-26 06:29 EDT, Norfaisal Ismail
no flags Details

  None (edit)
Description Norfaisal Ismail 2010-04-26 06:28:56 EDT
abrt 1.0.8 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/twistd -r gtk2 --pidfile /tmp/vmc.pid -noy /usr/share/vodafone-mobile-connect/gtk-tap.py -l /dev/null
component: python-twisted-core
executable: /usr/bin/twistd
kernel: 2.6.32.11-99.fc12.i686.PAE
package: python-twisted-core-8.2.0-3.fc12
reason: fedora.py:46:get_timezone:AttributeError: 'NoneType' object has no attribute 'groupdict'
release: Fedora release 12 (Constantine)

backtrace
-----
fedora.py:46:get_timezone:AttributeError: 'NoneType' object has no attribute 'groupdict'

Traceback (most recent call last):
  File "/usr/share/vodafone-mobile-connect/vmc/gtk/dialogs.py", line 345, in on_cancel_button_clicked
    self.cancel_func(*self.cancel_args)
  File "/usr/share/vodafone-mobile-connect/vmc/gtk/controllers/application.py", line 688, in default_eb
    self.model.disconnect_internet()
  File "/usr/share/vodafone-mobile-connect/vmc/gtk/models/application.py", line 133, in disconnect_internet
    d = self.connsm.close(hotplug)
  File "/usr/share/vodafone-mobile-connect/vmc/common/statem/connection.py", line 208, in close
    return self.do_next(hotplug)
  File "/usr/share/vodafone-mobile-connect/vmc/common/statem/connection.py", line 221, in do_next
    self.tracker.add_current_usage(restart=False)
  File "/usr/share/vodafone-mobile-connect/vmc/common/statem/connection.py", line 91, in add_current_usage
    tzinfo = osobj.get_tzinfo()
  File "/usr/share/vodafone-mobile-connect/vmc/common/plugin.py", line 288, in get_tzinfo
    zone = self.get_timezone()
  File "/home/faisal/.vmc2/plugins/os/fedora.py", line 46, in get_timezone
    search_dict = timezone_re.search(sysconf_clock_file).groupdict()
AttributeError: 'NoneType' object has no attribute 'groupdict'

Local variables in innermost frame:
sysconf_clock_file: '# The time zone of the system is defined by the contents of /etc/localtime.\n# This file is only for evaluation by system-config-date, do not rely on its\n# contents elsewhere.\nZONE="Asia/Kuala Lumpur"\n'
self: <vmc.common.plugins.fedora.FedoraBasedDistro object at 0x8c2298c>
timezone_re: <_sre.SRE_Pattern object at 0x8bf2ac8>

How to reproduce
-----
1.when run vmc
2.
3.
Comment 1 Norfaisal Ismail 2010-04-26 06:29:01 EDT
Created attachment 409141 [details]
File: backtrace
Comment 2 Thomas Vander Stichele 2010-05-24 06:28:32 EDT
This is an application bug and I have no idea why abrt points the finger at python-twisted-core... So that's a bug in abrt to fix.
Comment 3 Jiri Moskovcak 2010-05-24 06:42:05 EDT

*** This bug has been marked as a duplicate of bug 544986 ***

Note You need to log in before you can comment on or make changes to this bug.