Bug 58597 - guile not built with threading support
Summary: guile not built with threading support
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: guile   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-21 07:12 UTC by Ed Marshall
Modified: 2015-03-05 01:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-21 07:12:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed Marshall 2002-01-21 07:12:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7) Gecko/20011221

Description of problem:
Guile, as shipped by Red Hat, does not sport threading support, although (ice-9
threads) is there (fooling you into thinking it might work ;-).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run: guile -c '(use-modules (ice-9 threads)) (make-thread (display "Hello,
world!\n"))'

Actual Results:  ERROR: Unbound variable: call-with-new-thread

Expected Results:  "Hello, world!" ;-)

Additional info:

Easy fix: add --with-threads to the configure command line, and tack on
"%{_libdir}/libqthreads.so.*" to the %files section of the spec file.

This shouldn't destabilize anyone not using them; from the INSTALL file that
comes with guile (emphasis on the last sentence):

"Cooperative threads are not yet thoroughly tested; once they are, they will be
enabled by default.  The interaction with blocking I/O is pretty ad hoc at the
moment.  In our experience, bugs in the thread support do not affect you if you
don't actually use threads."

(By the way, you don't need "--enable-dynamic-linking" on the configure command
line anymore, since it's enabled by default on platforms that support it. Check
INSTALL for details.)

Comment 1 Phil Knirsch 2002-01-24 14:13:41 UTC
OK, fixed in latest version 1.3.4-17 available via rawhide real soon now. :)

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.