Bug 586011 - check for test being present in cvs
check for test being present in cvs
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.5
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 12:05 EDT by Karel Volný
Modified: 2010-04-29 14:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 14:55:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2010-04-26 12:05:19 EDT
Description of problem:
Submitting a test (make bkradd) is a process completely independent on presence of the test in cvs. While this may be handy from time to time, it hurts the maintainability. The version of the test in Beaker should be the same as in cvs. If for some reason there is a need to submit different version of the test, it has to be an explicit process, the special version should not "overwrite" the version tied to cvs and it should be marked appropriately.
Comment 1 Bill Peck 2010-04-29 14:55:05 EDT
I don't know how this would be done since tests can be written outside of Red Hat.    What you are talking about is policy.  Policy should be implemented by documentation and education.

Note You need to log in before you can comment on or make changes to this bug.