Bug 58602 - Installer throws exception from os.mkdir at end of install
Installer throws exception from os.mkdir at end of install
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-21 06:25 EST by Laurence Cotton
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-22 06:20:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Description of hardware and an example of install settings used (4.79 KB, patch)
2002-01-21 06:28 EST, Laurence Cotton
no flags Details | Diff

  None (edit)
Description Laurence Cotton 2002-01-21 06:25:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Installation disks frm : SAMS Teach Yourself Red Hat Linux
(ISBN 0-672-31845-8)

On attempting a first time install the installation seems to proceed Ok until 
near the end when an exception is thrown. It seems to be thrown from the call 
to os.mkdir(path, 0755) in iutil.py. Final error message is OSError: [Errno 17] 
File exists: '/mnt/sysimage/dev/hda1'.

See attatchments for full details.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Insert install disc 1 to cd rom and reboot
2.Select default install
3.Follow install wizard (custom) - used disk druid to set partitions
4.Select Install

Actual Results:  Message appeared : Formatting Filesystem and the install 
process continued by formatting the partitions and then installing the selected 
components.

The process seemed to be almost complete when the exception was thrown.

Expected Results:  Linux installation completed and reboot giving an option to 
boot into linux.

Additional info:

The traceback information displayed when the exception is thrown :
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1631, in 
doInstall
    self.fstab.write (self.instPath)
  File "fstab.py", line 742, in write
    iutil.mkdirChain(prefix + mntpoint)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 193, in 
mkdirChain
    os.mkdir(path, 0755)
OSError: [Errno 17] File exists: '/mnt/sysimage/dev/hda1'

I currently also have windows ME and windows 2000 installed.
My harddrive before the installation attempt is set up has folows :
size: 20G
C: 1.37G (Windows ME)
D: 13.6G (Windows 2000)
E: 4.02G (For Linux)
Comment 1 Laurence Cotton 2002-01-21 06:28:35 EST
Created attachment 43014 [details]
Description of hardware and an example of install settings used
Comment 2 Michael Fulbright 2002-01-21 12:30:42 EST
Did you enter a mount point for /dev/hda1 in Disk Druid? I see its a FAT
partition, so it isn't necessary for the install to complete.  I would try
installing w/o specifying any FAT mount points and see if the install completes.
Then afterwards we can add them to your system once its booting.
Comment 3 Laurence Cotton 2002-01-22 06:59:36 EST
Yes, I entered mount points for both windows ME (/dev/hda1) and windows 200 
(/dev/hda5). When I install without specifying these mount points the install 
process completes successfully. Thanks for that. Do you know what command I use 
to add these ? Do you know why the exception was throuwn if I include them 
during installation ?
Comment 4 Brent Fox 2002-01-24 23:21:47 EST
laurence, you can add mount points for your windows partitions by added entries
for them to the /etc/fstab file.  Since you say that your ME partition is on
/dev/hda1 and Win2k is on /dev/hda5, the lines that you need to add to
/etc/fstab will look like:

/dev/hda1      /mnt/winME         vfat     noauto,owner,users 0 0
/dev/hda5      /mnt/win2k         vfat     noauto,owner,users 0 0

Then, you'll be able to say 'mount /dev/hda1' to mount the WinME partition on
/mnt/winME and 'mount /dev/hda5' to mount the Win2k partition on /mnt/win2k.

I'm not sure why the traceback happened in the first place, though.  msf, any
ideas?  I've seen a number of these types of problems in the past, but I've
never been able to reproduce it.
Comment 5 Michael Fulbright 2002-02-21 15:31:01 EST
Was /dev/hda1 a pre-existing partition? Or did you make it in fdisk?
Comment 6 Laurence Cotton 2002-02-22 06:20:38 EST
/dev/hda1 existed as a windows partition before I installed linux. When I set 
up the partitions using disk druid I tried to mount it as /dev/hda1.
Comment 7 Jeremy Katz 2002-03-08 16:24:47 EST
/dev/hda1 is not a valid mountpoint.  You need to use something like
/mnt/windows.    The current partitioning framework is smarter about not letting
you choose mountpoints that are invalid.

Note You need to log in before you can comment on or make changes to this bug.