Bug 586269 - [RFE] Allow Remapping of Help Key
Summary: [RFE] Allow Remapping of Help Key
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: newt   
(Show other bugs)
Version: 13
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-27 07:53 UTC by Marko Myllynen
Modified: 2010-05-24 08:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 08:01:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marko Myllynen 2010-04-27 07:53:27 UTC
Description of problem:
Help key is currently hard coded to F1 so when running a newt application in gnome-terminal pressing F1 displays GNOME help, not the newt application help.

It would be nice if one could map hot keys like F1 to some arbitrary keys.

Version-Release number of selected component (if applicable):
Fedora 13

Comment 1 Marko Myllynen 2010-05-24 08:01:35 UTC
Actually it turns out that this is already possible with:

void newtFormAddHotKey(newtComponent co, int key)


Note You need to log in before you can comment on or make changes to this bug.