Bug 586366 - Simple Scan not allowing multi-session scanning
Simple Scan not allowing multi-session scanning
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: simple-scan (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 08:05 EDT by Boricua
Modified: 2011-03-01 02:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-01 02:08:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simple-scan log (920.40 KB, application/octet-stream)
2010-05-08 18:07 EDT, Boricua
no flags Details

  None (edit)
Description Boricua 2010-04-27 08:05:14 EDT
Description of problem: After one successful scanning, Simple Scan "new document" option does not allow to scan another document, forcing the user to close the program and open it again in order to continue.


Version-Release number of selected component (if applicable):


How reproducible: Every time I use the program.


Steps to Reproduce:
1. Scan a document.
2. Save the scanned document.
3. Push the new document icon and try to scan again.
  
Actual results: Nothing happens.


Expected results: To start a new document scan.


Additional info: The "new document" operation does erase the previously scanned document, but that's it.
Comment 1 Rahul Sundaram 2010-04-27 10:27:31 EDT

Test the new release build from 

http://koji.fedoraproject.org/koji/taskinfo?taskID=2141100

Let me know if it works better.  If it does not, please include the output of simple scan by running it from the command line, e.g.

$ simple-scan --debug >simple-scan.log
Comment 2 Boricua 2010-04-27 11:11:03 EDT
(In reply to comment #1)
> 
> Test the new release build from 
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2141100
> 
> Let me know if it works better.  If it does not, please include the output of
> simple scan by running it from the command line, e.g.
> 
> $ simple-scan --debug >simple-scan.log    

This one seems to be solved. Saving time is also decreased (i.e., better performance).
Comment 3 Boricua 2010-04-28 17:52:41 EDT
Hmmm, it seems I spoke too early. Problem is back.
Comment 4 Rahul Sundaram 2010-05-08 16:38:14 EDT
please include the output of simple scan by running it from the command line, e.g.

$ simple-scan --debug >simple-scan.log
Comment 5 Boricua 2010-05-08 18:05:45 EDT
(In reply to comment #4)
> please include the output of simple scan by running it from the command line,
> e.g.
> 
> $ simple-scan --debug >simple-scan.log    

I just noticed I can scan multiple single-page documents using the flatbed option. After using the ADF option, the issue appears.  Here is the output from the command line after trying three times after a successful ADF multipage scan:

[Francisco@Hogar Desktop]$ simple-scan --debug >simple-scan.log

** (simple-scan:7595): WARNING **: Unable to set front ADF source, please file a bug

** (simple-scan:7595): WARNING **: Unable to set front ADF source, please file a bug

** (simple-scan:7595): WARNING **: Unable to set front ADF source, please file a bug

I will upload the log next.
Comment 6 Boricua 2010-05-08 18:07:03 EDT
Created attachment 412578 [details]
simple-scan log
Comment 7 Rahul Sundaram 2010-06-08 11:50:27 EDT
Would you mind filing this upstream?

https://launchpad.net/simple-scan
Comment 8 Boricua 2010-06-09 20:27:38 EDT
(In reply to comment #7)
> Would you mind filing this upstream?
> 
> https://launchpad.net/simple-scan    

No problem. I will do the same with bug 586360 as also requested.

Note You need to log in before you can comment on or make changes to this bug.