This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 58638 - Installer crashes at post-installation step (hardrive based kickstart installation)
Installer crashes at post-installation step (hardrive based kickstart install...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-21 18:19 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda-generated bug report (114.91 KB, text/plain)
2002-01-21 18:21 EST, Need Real Name
no flags Details
Comment (117.06 KB, text/plain)
2002-01-21 18:19 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-01-21 18:19:11 EST
Created attachment 915088 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 1 Need Real Name 2002-01-21 18:21:46 EST
Created attachment 43095 [details]
Anaconda-generated bug report
Comment 2 Need Real Name 2002-01-22 17:59:55 EST
I found out that when forcing the installation to happen in text mode (by using 
the keyword text in the kickstart file), I was able to get past this error. 
Without the text keyword, the installation was defaulting to text mode anyway.

I seems that anaconda is losing track of this fact when doing the post-
installation and has a problem loading the "xmouse" script...

I have done the same type of installation with RH 6.2, 7.0, and 7.1 in the past 
and never had to force the text mode. I believe a bug was introduced in 7.2.
Comment 3 Michael Fulbright 2002-01-23 11:56:22 EST
I have not seen this issue with hard drive installs reported before. Have you
checked the md5sum of the ISO images you were using for the hard drive install?
Comment 4 Need Real Name 2002-01-23 13:00:29 EST
Yes I checked the md5sum of the ISO images that I used to create the CDs. And 
they are fine.
To create the harddrive base installation, I just copied the Redhat\base and 
redhat\rpms directories from the CDs to the harddrive.
Being done on a fat partition, (using the short filenames), it means that I had 
to rename a few RPM files that had duplicates shortnames on the CD1 and CD2, 
and merge the TRANS.TBL files. But as I said I have done that before with no 
problems at all with 6.2, 7.0 and 7.1. 
And I guess the workaround with 7.2 is to force the install to happen in text 
mode. I can select everything to be installed in the kick start file and it 
will work too. So I am not concerned about the validity of the images.
Comment 5 Michael Fulbright 2002-01-24 10:28:06 EST
Ah - for a hard drive install you just need to put the two ISO images in a
directory and point the install at that directory when asked for the location of
the files.  You do not have to mirror the contents of the ISOs onto the harddrive.

http://www.redhat.com/docs/manuals/linux/RHL-7.2-Manual/install-guide/s1-install-disk-image.html

has more info.
Comment 6 Need Real Name 2002-01-28 14:26:32 EST
I tried with the ISO-images, but now the installation is not unattended anymore.
I put the images in test/redhat and I specified the
hardrive --partition sda1 --dir test 
in the kickstart file. But it did not work. (I also tried --dir test/redhat and 
it did not work either) I am installing using a FAT partition. So I even 
created TRANS.TBL file to establish "links", but it still failed.
Anaconda asks me the language, the keyboard and finally the partition directory.
Once these questions answered, (note that I have to specify rh/redhat for the 
directory and not rh only) the installation proceeds unattended and does not 
exhibit the post-installation crash even though I did not specify text in the 
kickstart.
So in short, using the ISO images solved the problem but created another one.
Comment 7 Jeremy Katz 2002-03-13 00:46:18 EST
msf was looking at hard-drive based kickstart installs earlier today
Comment 8 Michael Fulbright 2002-03-26 19:35:32 EST
Fixed.
Comment 9 Red Hat Bugzilla 2006-02-21 13:48:22 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.