Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 586464 - Display cut on the rigth - Dell Vostro 230
Display cut on the rigth - Dell Vostro 230
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 12:45 EDT by Ludovic Danigo
Modified: 2010-07-08 23:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 23:00:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
version of installed rpms (181 bytes, text/plain)
2010-04-27 12:45 EDT, Ludovic Danigo
no flags Details
dmesg (39.28 KB, text/plain)
2010-04-27 12:46 EDT, Ludovic Danigo
no flags Details
lspci -vv (24.59 KB, text/plain)
2010-04-27 12:46 EDT, Ludovic Danigo
no flags Details
monitor-edid output (407 bytes, text/plain)
2010-04-27 12:47 EDT, Ludovic Danigo
no flags Details
Xorg log (230.46 KB, application/octet-stream)
2010-04-27 12:48 EDT, Ludovic Danigo
no flags Details
kernel version (103 bytes, text/plain)
2010-04-27 12:49 EDT, Ludovic Danigo
no flags Details
dmesg with drm.debug=15 set on boot (122.91 KB, text/plain)
2010-04-27 12:49 EDT, Ludovic Danigo
no flags Details
messages log with drm.debug=15 set on boot (3.79 MB, text/plain)
2010-04-27 12:55 EDT, Ludovic Danigo
no flags Details

  None (edit)
Description Ludovic Danigo 2010-04-27 12:45:08 EDT
Created attachment 409517 [details]
version of installed rpms

The Dell Votro comes with an nvidia card and a display with native 1920x1080 resolution. Yet at full resolution the screen is cut on the right. My take is that KMS is not setting the right modeline.
Comment 1 Ludovic Danigo 2010-04-27 12:46:04 EDT
Created attachment 409518 [details]
dmesg
Comment 2 Ludovic Danigo 2010-04-27 12:46:57 EDT
Created attachment 409519 [details]
lspci -vv
Comment 3 Ludovic Danigo 2010-04-27 12:47:31 EDT
Created attachment 409520 [details]
monitor-edid output
Comment 4 Ludovic Danigo 2010-04-27 12:48:16 EDT
Created attachment 409521 [details]
Xorg log
Comment 5 Ludovic Danigo 2010-04-27 12:49:03 EDT
Created attachment 409522 [details]
kernel version
Comment 6 Ludovic Danigo 2010-04-27 12:49:47 EDT
Created attachment 409523 [details]
dmesg with drm.debug=15 set on boot
Comment 7 Ludovic Danigo 2010-04-27 12:55:15 EDT
Created attachment 409527 [details]
messages log with drm.debug=15 set on boot
Comment 8 Ludovic Danigo 2010-04-27 12:56:04 EDT
Smolts profile :
http://www.smolts.org/client/show/pub_9dfb143b-1cef-415c-9721-92ea139a411d
Comment 9 Ben Skeggs 2010-04-27 20:57:12 EDT
Hmm, I only have one idea what may be happening here so far, I'm actually working on a fix for the problem for a different issue.  I will update you once there's something to test.

Thank you!
Comment 10 Ben Skeggs 2010-04-29 19:17:00 EDT
Can you give kernel-2.6.33.3-73.fc13
(http://koji.fedoraproject.org/koji/buildinfo?buildID=169330) a try and see if there's any improvement?
Comment 11 Ludovic Danigo 2010-04-30 06:53:08 EDT
I did give it a try and that fixed it. Well there are still 2-3 millimetres missing but I can live with that ! I've tested 2.6.33.3-73.fc13.i686.PAEdebug + debuginfo so if you think you migth need more info on whatever related to this chip.

Many thanks for that quick resolution (no pun intended :-D)
Comment 12 Luigi Pardey 2010-05-02 09:47:38 EDT
Ludovic, did updating the kernel fix the issue in a 100%?
Or you reckon there is still to improve? (judging by your words "2-3 millimetres missing")



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Ludovic Danigo 2010-05-03 09:44:37 EDT
To be 100% acurate there is still a little room for improvement.
2-3 millimetres missing are still missing on the right.
Yet that's far better than a third of screen missing ;-)
Is that easily fixable ?
Comment 14 Ben Skeggs 2010-05-03 19:26:05 EDT
Are you able to get an image of the display?  And, does the "vesa" and/or nvidia binary driver show the same issue?
Comment 15 Ludovic Danigo 2010-05-05 07:26:56 EDT
I do get an image. The driver is working great. I did not try nor vesa nor nvidia driver. I just had the problem with the screen native resolution : 1920x1080 had the image cut on the right. @1280x1024 the image wasn't cut.

To be perfect there are still 2-3 milimeters missing on the right of the screen but situation is much better with the patch than it was before.
Comment 16 Ben Skeggs 2010-06-01 21:30:20 EDT
Do you consider this issue resolved?  If not, it'd be great if you could try with the NVIDIA binary driver and see if they do any better.  If they can't, it's likely we can't either :)
Comment 17 Ludovic Danigo 2010-07-08 11:22:28 EDT
Hi,

sorry for answering late. We can consider this issue resolved as I have since managed to find the time to installed the NVidia binary driver to compare and it is exhibiting the same behaviour. So I thank you for your very good work.
Comment 18 Ben Skeggs 2010-07-08 23:00:39 EDT
Cool, thank you very much :)

Note You need to log in before you can comment on or make changes to this bug.