Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 586494 - chvt command missing from EL6 install image
chvt command missing from EL6 install image
Status: CLOSED DUPLICATE of bug 575844
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 13:58 EDT by Don Hoover
Modified: 2010-04-27 15:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 14:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Hoover 2010-04-27 13:58:53 EDT
Description of problem:
The chvt command is missing from the EL6 installation image. 

This command was typically used during %pre and %post scripts to switch to a virtual console to show output to the user, and/or collect input. 

I think this command is gone because busybox is no longer used in the install/anaconda environment.   The standalone chvt executable should be added to the installation image.

Version-Release number of selected component (if applicable):
RHEL 6 Beta 1

How reproducible:
chvt command not found

Steps to Reproduce:
1.
2.
3.
  
Actual results:
chvt command not found

Expected results:
use chvt to switch to the appropriate virtual terminal

Additional info:
Can the chvt command be added back into the installation image?
Comment 2 David Cantrell 2010-04-27 14:18:14 EDT

*** This bug has been marked as a duplicate of bug 575844 ***
Comment 3 Mike Jennings 2010-04-27 15:47:39 EDT
OpenVT is available to switch to a new terminal.

Note You need to log in before you can comment on or make changes to this bug.