Bug 58657 - gcc-3.1-0.18 miscompilation on rpm build/files.c
Summary: gcc-3.1-0.18 miscompilation on rpm build/files.c
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-22 13:30 UTC by Jeff Johnson
Modified: 2007-04-18 16:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 19:56:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch in build/files.c (1.21 KB, patch)
2002-01-22 13:32 UTC, Jeff Johnson
no flags Details | Diff
temp file (479.32 KB, patch)
2002-01-22 13:46 UTC, Jeff Johnson
no flags Details | Diff

Description Jeff Johnson 2002-01-22 13:30:15 UTC
gcc-3.1-0.18 is miscompiling rpm-4.0.4-0.15 build/files.c

Workaround was to add attached patch and compile build/files.c
with CFLAGS="-g -O0 -DIA64_SUCKS_ROCKS"

Comment 1 Jeff Johnson 2002-01-22 13:32:52 UTC
Created attachment 43174 [details]
patch in build/files.c

Comment 2 Jeff Johnson 2002-01-22 13:46:32 UTC
Created attachment 43175 [details]
temp file

Comment 3 Jakub Jelinek 2002-01-22 18:21:57 UTC
Were you seeing the problem in all 3 places or just one?
If just in the stpcpy(foo, "./") case, then it is a different thing than
the other two...

Comment 4 Jeff Johnson 2002-01-22 19:01:30 UTC
Ah, overriding CFLAGS="-g -O0 -DIA64_SUCKS_ROCKS" (note missing
-D_GNU_SOURCE) explains the warning.

However it does *NOT* explain why I don't get the warning when the
same command is repeated a bit later. WTFO?

And I get segfaults when trying to repeat results of last night.

FWIW, rpm-4.0.4-0.15 built this morning, is installed and running
on bullwinkle with the missing -D_GNU_SOURCE -D_REENTRANT
compilation patch as described.

Appears that there's some uncontrolled for condition related to
bullwinkle. I believe my so called patch just happens to work.
Temperature?

And yes, the problem is/was invariant to disabling each of the 3
stpcpy chunks.

Comment 5 Jeff Johnson 2002-01-22 20:05:39 UTC
Hmmm, after trying again the warning message is repeatable.
Good, I'm not insane, just distracted.

We'll see whether rpm-4.0.4-0.16 builds repeatably on ia64.

Comment 6 Jeff Johnson 2002-01-22 22:00:14 UTC
OK, here's what I see:

boris can build rpm-4.0.4-0.16 w hack, runs on bullwinkle OK.

bullwinkle can build -0.16 w hack, runs on bullwinkle OK.

bullwinkle can build -0.16 w/o hack, does NOT run on bullwinkle..

Off to build w/o hack on boris to eliminate build tree problems, otherwise
the problem is as likely to be the missing -D_GNU_SOURCE and -D_REENTRANT
as something else.

Comment 7 Jeff Johnson 2002-01-22 22:46:17 UTC
Build on boris w/o hack does NOT run on boris.

That eliminates (well minimizes) build tree pollution.

I'm kinda stumped here. Ideas on how to proceed?

Comment 8 Jakub Jelinek 2002-02-08 10:40:32 UTC
Can you tell me the exact way to reproduce the problem (ie. what should
I exactly run in the buildroot after I build rpm w/o hack)?

Comment 9 Jakub Jelinek 2004-10-02 19:56:16 UTC
No testcase and the bug is too old.


Note You need to log in before you can comment on or make changes to this bug.