Bug 586581 - Screen flicker when using Thinkpad T500 integrated graphics
Screen flicker when using Thinkpad T500 integrated graphics
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 18:03 EDT by Devin Reade
Modified: 2010-06-03 17:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-03 17:03:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (51.61 KB, text/plain)
2010-04-27 18:03 EDT, Devin Reade
no flags Details

  None (edit)
Description Devin Reade 2010-04-27 18:03:42 EDT
Created attachment 409600 [details]
dmesg output

Description of problem:

When "integrated graphics" is selected in the T500 BIOS, the graphics
screen (starting with the red boot screen and continuing with the window
manager after login) has a very distinct flicker.  It is not regular like
you would associate with a refresh rate; it is random and quite obvious.

If instead one selects "discrete graphics" mode in the BIOS and reboots, 
there is no flicker effect. (Unfortunately, discrete graphics mode is also
more power hungry.)

Please let me know if there are additional diags that you require (dmesg
is attached).

Version-Release number of selected component (if applicable): RHEL 6.0 Beta

How reproducible: Continuous.


Steps to Reproduce:
1. Set graphics mode to "integrated" in BIOS
2. Reboot

Additional info:

Thinkpad T500 model 2081-CTO with 15.4" WSXGA+ TFT (1680x1050)
Integrated graphics: Intel Graphics Media Accelerator (GMA) 4500MHD
Discrete graphics:   ATI Mobility Radeon 3650 w/ 256MB
Comment 2 RHEL Product and Program Management 2010-04-27 19:13:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Matěj Cepl 2010-04-28 02:05:55 EDT
Does the issue go away if you add i915.powersave=0 to the kernel command line?

Thank you for helping as making RHEL better
Comment 4 Devin Reade 2010-04-28 15:48:32 EDT
The flickering does indeed go away if i915.powersave=0 is added to the kernel command line (via grub.conf).

I also determined that (without this parameter) the amount of flickering is proportional to mouse movements.  Perhaps interrupt related?

Googling i915.powersave shows that this may be a duplicate of
https://bugzilla.redhat.com/show_bug.cgi?id=519734
Comment 5 Adam Jackson 2010-06-03 17:03:10 EDT
I suspect this is fixed by:

commit 33c5fd121eabbccc9103daf6cda36941eb3c349f
Author: David John <davidjon@xenontk.org>
Date:   Wed Jan 27 15:19:08 2010 +0530

    drm/i915: Disable SR when more than one pipe is enabled

which is included in kernel -20 and later.

Please re-open if you can reproduce this on later kernels.

Note You need to log in before you can comment on or make changes to this bug.