Bug 586712 - Static IPv6 address does not survive a reboot(dual stacked system)
Summary: Static IPv6 address does not survive a reboot(dual stacked system)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-28 08:40 UTC by Svante Victorsson
Modified: 2010-05-07 19:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-07 19:34:01 UTC
Type: ---


Attachments (Terms of Use)

Description Svante Victorsson 2010-04-28 08:40:25 UTC
Description of problem:
IPv6 address is configured via the GUI Network Connections -> system eth0 -> IPv6 tab

Method: Manual
Address: 2001:2040:0:1:: c
Prefix: 120

Routes
Address: ::
Access Code: 0
Gateway: 2001:2040:0:1:: 1

After rebooting the system configuration is shown in the GUI, but no IPv6 functionality.
After restarting the network manually, /etc/init.d/network restart
Full IPv6 functionality is achieved

Version-Release number of selected component (if applicable):

uname -a : Linux digger.secure-dns.se 2.6.32.11-99.fc12.i686.PAE #1 SMP Mon Apr 5 16:15:03 EDT 2010 i686 i686 i386 GNU/Linux
system-config-network.noarch  1.6.0-2.fc12
avahi.i686                    0.6.25-5.fc12
nss-mdns.i686                 0.10-8.fc12

How reproducible:
Happens every time system is rebooted

Steps to Reproduce:
1. configure for ipv6 via the GUI, once
2. rebooting the system

# ifconfig
eth0      Link encap:Ethernet  HWaddr 18:A9:05:2D:7A:A4  
          inet addr:195.198.153.12  Bcast:195.198.153.255  Mask:255.255.255.0
          inet6 addr: fe80::1aa9:5ff:fe2d:7aa4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:71386 errors:0 dropped:0 overruns:0 frame:0
          TX packets:80843 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:33226768 (31.6 MiB)  TX bytes:54940394 (52.3 MiB)
          Memory:f0500000-f0520000 

3. restarting the network, manually

# ifconfig
eth0      Link encap:Ethernet  HWaddr 18:A9:05:2D:7A:A4  
          inet addr:195.198.153.12  Bcast:195.198.153.255  Mask:255.255.255.0
          inet6 addr: fe80::1aa9:5ff:fe2d:7aa4/64 Scope:Link
          inet6 addr: 2001:2040:0:1::c/120 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:71386 errors:0 dropped:0 overruns:0 frame:0
          TX packets:80843 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:33226768 (31.6 MiB)  TX bytes:54940394 (52.3 MiB)
          Memory:f0500000-f0520000 

  
Actual results:
On bootup, Static IPv6 configuration is ignored. 
IPv4 configuration is handled correct and is working.

Expected results:
Ethernet IPv6 address is assigned the given IP address.

Additional info:

/etc/sysconfig/network-scripts/ifcfg-eth0:
=====================================

# Intel Corporation 82567LM-3 Gigabit Network Connection
DEVICE=eth0
BOOTPROTO=none
DNS1=195.67.199.18
GATEWAY=195.198.153.1
HWADDR=18:A9:05:2D:7A:A4
IPADDR=195.198.153.12
NETMASK=255.255.255.0
ONBOOT=yes
TYPE=Ethernet
NM_CONTROLLED=yes
USERCTL=no
PREFIX=24
NAME="System eth0"
UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03
DEFROUTE=yes

IPV6ADDR=2001:2040:0:1::c/120
IPV6_DEFAULTGW=2001:2040:0:1::1
IPV6INIT=yes

IPV6_AUTOCONF=no
IPV6_DEFROUTE=yes

Comment 1 iarly selbir 2010-04-28 11:46:22 UTC
I noticed you're using NM, I already had problems previous with NM ignoring my settings made by hand on ifcf-* files.

for testing purpose try NM_CONTROLLED=no


Thanks for your report.

--
Fedora Bugzappers Team Member

Comment 2 Dan Williams 2010-04-30 00:35:00 UTC
(In reply to comment #1)
> I noticed you're using NM, I already had problems previous with NM ignoring my
> settings made by hand on ifcf-* files.
> 
> for testing purpose try NM_CONTROLLED=no

If NM is ignoring something, it's a bug and we will fix it...

Comment 3 Dan Williams 2010-05-03 12:28:34 UTC
Please try these updated builds for F13 or F12:

https://admin.fedoraproject.org/updates/NetworkManager-0.8.0-11.git20100503.fc13
https://admin.fedoraproject.org/updates/NetworkManager-0.8.0-11.git20100503.fc12

I've tested them with your ifcfg file and they appear to work correctly.

Comment 4 Svante Victorsson 2010-05-06 09:37:05 UTC
Hi,
Sure i can try.
But please help with this.

yum install NetworkManager-*

Packet NetworkManager-gnome-0.8.0-11.git20100503.fc12.i686.rpm is not signed

So how am I supposed to install these packets.

NetworkManager       1:0.8.0-11.git20100503.fc12                              
NetworkManager-glib  1:0.8.0-11.git20100503.fc12                              
NetworkManager-gnome 1:0.8.0-11.git20100503.fc12

I have tried rpm-ivh package above, but received a great amount of conflicting dependencies.

It is perhaps easy, but I do not know how to do....

Comment 5 Dan Williams 2010-05-06 23:45:35 UTC
Try now: 

yum --enablerepo=updates-testing update NetworkManager

It's been pushed to the testing repo and thus will now be signed.

Comment 6 Svante Victorsson 2010-05-07 08:26:38 UTC
Hi, 
Thanks for the command line. 
I have now installed and reboot my system and it seems that the configuration does well and I have IPv6 functionality without further configuration.

In other words - it works as intended.

Thanks
Svante

Comment 7 Dan Williams 2010-05-07 19:34:01 UTC
Ok, thanks for confirming.


Note You need to log in before you can comment on or make changes to this bug.