Bug 586758 - Virt-v2v will defect minor version when the guest is >= rhel5 XenPV
Virt-v2v will defect minor version when the guest is >= rhel5 XenPV
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
5.5
All Linux
high Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 06:24 EDT by Rita Wu
Modified: 2013-07-02 21:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 04:40:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-v2v.conf (3.70 KB, text/plain)
2010-04-28 06:24 EDT, Rita Wu
no flags Details
xen-rhel54-64-pv-raw.img.xml (1.10 KB, text/plain)
2010-04-28 06:33 EDT, Rita Wu
no flags Details

  None (edit)
Description Rita Wu 2010-04-28 06:24:44 EDT
Created attachment 409754 [details]
virt-v2v.conf

Description of problem:
It happens on:
rhel54-32-pv
rhel54-64-pv
rhel55-32-pv
rhel55-64-pv 

But it's OK both on rhel4u8-32-pv and thel4u8-64-pv

Version-Release number of selected component (if applicable):
v2v-libvirt-0.8.0-2.el5
virt-v2v-0.5.1-1.el5


How reproducible:
100%

Steps to Reproduce:

# virt-v2v -f /usr/share/doc/virt-v2v-0.5.1/virt-v2v.conf -i libvirtxml -o rhev -osd 10.66.90.115:/vol/ovirt1/auto/v2v/export /tmp/xen-rhel54-64-pv-raw.img.xml
virt-v2v: No app in config matches distro='rhel' name='rhel/5/ecryptfs-utils-56-8.el5.x86_64.rpm' major='5' minor='4' arch='x86_64'
virt-v2v: Failed to unmount 10.66.90.115:/vol/ovirt1/auto/v2v/export. Command exited with status 1. Output was: umount: /tmp/L6DTf69Liu: device is busy
umount: /tmp/L6DTf69Liu: device is busy

virt-v2v: Failed to remove mount directory /tmp/L6DTf69Liu: Device or resource busy
Error: Convert image xen-rhel54-64-pv-raw.img failed

  
Actual results:
as steps 

Expected results:
convert successfully

Additional info:
Comment 1 Rita Wu 2010-04-28 06:33:00 EDT
Created attachment 409759 [details]
xen-rhel54-64-pv-raw.img.xml
Comment 2 Richard W.M. Jones 2010-04-28 07:25:42 EDT
(In reply to comment #0)
> virt-v2v: Failed to unmount 10.66.90.115:/vol/ovirt1/auto/v2v/export. Command
> exited with status 1. Output was: umount: /tmp/L6DTf69Liu: device is busy
> umount: /tmp/L6DTf69Liu: device is busy

Matt, strange error there?
Comment 3 Matthew Booth 2010-04-29 04:40:57 EDT
Linglu,

The error message you're getting about umount is certainly odd. However, the underlying issue here is that the config file format changed for app dependencies between 0.4.10 and 0.5.1 (sorry again!). It's trying to look for a key called 'rhel/5/ecryptfs-utils-56-8.el5.x86_64.rpm' when it should be looking for a key called 'ecryptfs-utils'.

The reason this works for RHEL 4 is that there are no kernel dependencies for RHEL 4.

Note You need to log in before you can comment on or make changes to this bug.