Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 586813 - Force page cache to be sent in sequential order [NEEDINFO]
Force page cache to be sent in sequential order
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 08:19 EDT by Charlie Wyse
Modified: 2014-06-03 08:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:29:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (cwyse)


Attachments (Terms of Use)

  None (edit)
Description Charlie Wyse 2010-04-28 08:19:28 EDT
Description of problem:
When a system is receiving a lot of write data, say from NFS.  The pages are written out to disk in no particular order.  This can cause issues with some file systems.  The ability to force synchronization of pages written to disk would be helpful.

How reproducible:
Happsn with current VM configurations

Steps to Reproduce:
1. Setup a NFS server, then send a 8g file to it.
2. If you look at the code you will see several offsets as it places data anywhere in that 8g file in as it sees fit.
  
Actual results:
Data is written to disk out of order.

Expected results:
Some kind of option to force data to be sync'ed in memory before written.
Comment 1 RHEL Product and Program Management 2014-03-07 07:52:05 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-03 08:29:54 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.