Bug 58693 - Cannot upgrade curl package
Cannot upgrade curl package
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: curl (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-23 04:07 EST by Mario Mikocevic
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-29 02:35:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Mikocevic 2002-01-23 04:07:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020120

Description of problem:
Cannot upgrade curl package from curl-7.8-1 to currently latest
curl-7.9.2-2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -Fvh curl-7.9.2-2.i386.rpm
2.
3.
	

Actual Results:  # rpm -Fvh curl*
error: failed dependencies:
        libcurl.so.1   is needed by php-4.0.6-13

# rpm -ivh curl-7.9.2-2.i386.rpm
Preparing...                ########################################### [100%]
file /usr/bin/curl from install of curl-7.9.2-2 conflicts with file from package
curl-7.8-1
file /usr/share/man/man1/curl.1.gz from install of curl-7.9.2-2 conflicts with
file from package curl-7.8-1


Expected Results:  Upgrade done.

Additional info:

Neither upgrade nor concurrent instalation is possible.
I think that php should be recompiled with new curl or
new curl1 package should be made.
Comment 1 Trond Eivind Glomsrxd 2002-01-28 14:40:54 EST
You can't update it, because other components are built against it. A newer curl
is, as you see, already in the development tree.
Comment 2 Mario Mikocevic 2002-01-29 02:35:00 EST
NO, it IS A BUG !
Person _should_ be able to _upgrade_ one way or another !

Yes, the new package is in the devel tree but it _behaves_ exactly as
the previous one ->

# rpm -Uvh curl-7.9.3-1.i386.rpm 
error: failed dependencies:
        libcurl.so.1   is needed by php-4.0.6-13
# rpm -ivh curl-7.9.3-1.i386.rpm
Preparing...                ########################################### [100%]
file /usr/bin/curl from install of curl-7.9.3-1 conflicts with file from package
curl-7.8-1
file /usr/share/man/man1/curl.1.gz from install of curl-7.9.3-1 conflicts with
file from package curl-7.8-1

As long as old package has
-rwxr-xr-x    1 root    root           122835 Kol 21 18:16 /usr/lib/libcurl.so.1.1.0

and the new one _NEW_ library series
-rwxr-xr-x    1 root    root           156351 Sij 24 01:54 /usr/lib/libcurl.so.2.0.2

any inability to install them _both_ is a BUG !
And yes, I know it's a rawhide and I have --force and --nodeps
options but this time it is not the proper way nor time to use them.

Comment 3 Trond Eivind Glomsrxd 2002-02-08 14:45:43 EST
Not being able to upgrade to devel packages because of depencies is _not_ a bug.
Devel packages are built against each other, not an old release.

Note You need to log in before you can comment on or make changes to this bug.