Bug 58702 - Nautilus will not run - nautilus: error while loading shared libraries: /usr/lib/libgnomeprint.so.15: unexpected PLT reloc type 0x00
Nautilus will not run - nautilus: error while loading shared libraries: /usr/...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-23 08:08 EST by Ken Pratt
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 11:57:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Pratt 2002-01-23 08:08:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.2 (X11; Linux i686; U;) Gecko/20011226

Description of problem:
When I log in from XDM, nautilus does not start.  If I bring up a terminal
window and type 'nautilus', I receive the following and nautilus still does not
start.

nautilus: error while loading shared libraries: /usr/lib/libgnomeprint.so.15:
unexpected PLT reloc type 0x00

I'm using a Dell Inspiron 8000 with 128M RAM and have updated all packages
including the kernel using up2date

PS: Printing does work.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RedHat Linux 7.2 on Dell Inspiron 8000
2. Update everything including kernel using up2date
3. Delete old kernel RPM
4. Reboot and log in
5. Nautilus will not run
	

Actual Results:  nautilus: error while loading shared libraries:
/usr/lib/libgnomeprint.so.15: unexpected PLT reloc type 0x00

Expected Results:  Nautilus should start

Additional info:

Sometimes the panel app will not start.  It simply segfaults.  Usually when this
happens, nautilus will run.  It is an either or situation.
Comment 1 Havoc Pennington 2002-01-23 11:57:26 EST
Something is wrong with your system. Are you using prelink? Any non-Red-Hat
packages? Can you attach "rpm -V gnome-print nautilus" output? Can you start say
Gnumeric?
Comment 2 Havoc Pennington 2002-02-27 12:45:27 EST
Can't reproduce, have no other reports like this.

Conceivably related to #56506
Comment 3 Ken Pratt 2002-02-27 16:52:53 EST
I am still unable to install a RedHat 7.2 distribution with all updates on my
laptop without the Nautilus problem occurring. I've since noticed that if I try
to repeatedly log in, sometimes Nautilus will start fine.  When this happend the
gnome-panel segfaults.  It will not run even from the command line.  It is an
XOR situation between Nautilus and gnome-panel.  One or the other will operate -
but not both.

However, if I install Ximain, all problems go away...
Comment 4 Havoc Pennington 2002-02-27 18:03:03 EST
If you want to keep debugging it, you could try some of the things mentioned
on #56506 such as ide=nodma, strace, and LD_DEBUG=all and report whether
ide=nodma helps and attach the LD_DEBUG or strace output.

It'd be useful to just put further comments on #56506 so they're all in one place.

Note You need to log in before you can comment on or make changes to this bug.