Bug 58704 - Loses DHCPCDARGS
Loses DHCPCDARGS
Status: CLOSED DUPLICATE of bug 57927
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-23 08:57 EST by Enrico Scholz
Modified: 2014-03-16 22:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 14:54:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-01-23 08:57:24 EST
Description of Problem:

/etc/sysconfig/network-scripts/ifup contains:

|    DHCPCDARGS="$DHCPCDARGS -n"
|    if [ -n "${DHCP_HOSTNAME}" ]; then
|       PUMPARGS="-h ${DHCP_HOSTNAME}"
|       DHCPCDARGS="-h ${DHCP_HOSTNAME}"

which means that a manually set DHCPCDARGS (e.g. by entries in
/etc/sysconfig/network) will be overwritten if DHCP_HOSTNAME is set.

I suggest to write the last 2 lines as:

|       PUMPARGS="${PUMPARGS} -h ${DHCP_HOSTNAME}"
|       DHCPCDARGS="${DHCPCDARGS} -h ${DHCP_HOSTNAME}"



Version-Release number of selected component (if applicable):

initscripts-6.40.2-1
Comment 1 Olivier Baudron 2002-01-23 14:54:11 EST
Already reported 3 weeks ago as bug 57927.
Comment 2 Bill Nottingham 2002-01-24 02:17:07 EST

*** This bug has been marked as a duplicate of 57927 ***

Note You need to log in before you can comment on or make changes to this bug.