Bug 587050 - Updating glibc replaces /etc/rpc without warning or backup
Updating glibc replaces /etc/rpc without warning or backup
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
: Triaged
: 644671 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 14:33 EDT by Kelvin Ku
Modified: 2016-11-24 11:03 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.12.90-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-05 09:21:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kelvin Ku 2010-04-28 14:33:19 EDT
Description of problem: Updating glibc replaces /etc/rpc without emitting a warning or creating a backup

Version-Release number of selected component (if applicable):

glibc-2.11.1-4.x86_64

How reproducible:

Always

Steps to Reproduce:
1. yum update glibc
2.
3.
  
Actual results:

/etc/rpc is overwritten

Expected results:

A warning and/or backing up /etc/rpc to, e.g., /etc/rpc.rpmsave

Additional info:
Comment 1 d. johnson 2010-06-30 15:57:27 EDT
glibc-2.11.2-1 (f12) did not mark "/etc/rpc" as a %config file.

glibc-2.12-2 (f13) likewise did not.
Comment 2 d. johnson 2010-07-06 12:36:27 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Andreas Schwab 2010-10-20 04:23:44 EDT
*** Bug 644671 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.