Bug 587052 - [abrt] crash in firefox-3.5.9-1.fc12: Process /usr/lib/firefox-3.5.9/firefox was killed by signal 6 (SIGABRT)
[abrt] crash in firefox-3.5.9-1.fc12: Process /usr/lib/firefox-3.5.9/firefox ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:47a11504a334cab9e10f730b1f4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 14:35 EDT by Dan Hrabarchuk
Modified: 2010-05-07 07:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 07:42:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (74.46 KB, text/plain)
2010-04-28 14:35 EDT, Dan Hrabarchuk
no flags Details

  None (edit)
Description Dan Hrabarchuk 2010-04-28 14:35:54 EDT
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.5.9/firefox
component: firefox
executable: /usr/lib/firefox-3.5.9/firefox
kernel: 2.6.32.10-90.fc12.i686.PAE
package: firefox-3.5.9-1.fc12
rating: 4
reason: Process /usr/lib/firefox-3.5.9/firefox was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)
Comment 1 Dan Hrabarchuk 2010-04-28 14:35:56 EDT
Created attachment 409936 [details]
File: backtrace
Comment 2 Chris Campbell 2010-05-07 07:41:25 EDT
Thread 1 (Thread 6237):
#0  0x00b50424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x007ef000 in raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/pt-raise.c:42
        resultvar = <value optimized out>
        resultvar = <value optimized out>
        pid = <value optimized out>
#2  0x045d94f3 in nsProfileLock::FatalSignalHandler (signo=6)
    at nsProfileLock.cpp:212
        unblock_sigs = {__val = {32, 0 <repeats 31 times>}}
        oldact = <value optimized out>
#3  0x079e2425 in mono_chain_signal (_dummy=6, info=0xb77fa72c, 
    context=0xb77fa7ac) at mini-posix.c:133
No locals.
#4  0x079e2826 in sigabrt_signal_handler (_dummy=6, info=0xb77fa72c, 
    context=0xb77fa7ac) at mini-posix.c:153
        ji = <value optimized out>
#5  <signal handler called>
No symbol table info available.
#6  0x00b50424 in __kernel_vsyscall ()
No symbol table info available.
#7  0x0068da91 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = <value optimized out>
        resultvar = <value optimized out>
        pid = 8208372
        selftid = 6237
#8  0x0068f35a in abort () at abort.c:92
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0xb77fabb0, 
            sa_sigaction = 0xb77fabb0}, sa_mask = {__val = {2902392248, 
              3078597508, 6597928, 3078597492, 17229340, 3078597480, 6687292, 
              0, 2901382432, 5, 0, 1, 2902391808, 134595032, 2838798336, 
              2838798336, 3078597464, 134567132, 3077496896, 3078597184, 
              6684612, 0, 3078597552, 3078597480, 3078597492, 2838496120, 
              2902391808, 0, 17443080, 3077496896, 1601, 2838800384}}, 
          sa_flags = 134566843, sa_restorer = 0x42f81a4}
        sigs = {__val = {32, 0 <repeats 31 times>}}
#9  0x01166ce0 in moonlight_handle_native_sigsegv (signal=11) at debug.cpp:739
        signal_str = 0x13458da "SIGSEGV"
#10 0x079e2425 in mono_chain_signal (_dummy=11, info=0xb77fac8c, 
    context=0xb77fad0c) at mini-posix.c:133
No locals.
#11 0x0791fffb in mono_sigsegv_signal_handler (_dummy=11, info=0xb77fac8c, 
    context=0xb77fad0c) at mini.c:4813
        ji = 0x0
#12 <signal handler called>
No symbol table info available.
#13 0x0116c996 in DependencyObject::RegisterAllNamesRootedAt (
    this=0xa957ca00, to_ns=0xa94eea60, error=0x0) at dependencyobject.cpp:1631
        autocreate = 0xa9337420
        merge_namescope = true
        register_name = 60
        recurse = 191
        this_ns = 0xa94eea60
#14 0x0116f1c1 in DependencyObject::SetParent (this=0xa957ca00, 
    parent=0xb7549a60, error=0x0) at dependencyobject.cpp:2723
        temp_scope = 0xa94eea60
        this_scope = 0x0
        parent_scope = 0xa94ee150
        current = 0x0
#15 0x0116fa3a in DependencyObject::ProviderValueChanged (this=0xb7549a60, 
    providerPrecedence=PropertyPrecedence_LocalValue, property=0xaa9fc4c0, 
    old_provider_value=0x0, new_provider_value=0xa9337490, 
    notify_listeners=true, set_parent=true, error=0x0)
    at dependencyobject.cpp:1935
        old_as_dep = 0xaa9f9380
        new_as_dep = 0xa957ca00
        setsParent = true
        p = -1
        old_value = 0xaa9fac60
        new_value = 0xa9337490
        equal = false
#16 0x01170431 in DependencyObject::SetValueWithErrorImpl (this=0xb7549a60, 
    property=0xaa9fc4c0, value=0xa9337480, error=0x0)
    at dependencyobject.cpp:1584
        new_value = 0xa9337490
        autocreate = 0xa9316e40
        current_value = 0x0
        equal = false
#17 0x0116ceb8 in DependencyObject::SetValueWithError (this=0xb7549a60, 
    property=0xaa9fc4c0, value=0xa9337480, error=0x0)
    at dependencyobject.cpp:1601
No locals.
#18 0x012a434a in xaml_set_property_from_str (obj=0xb7549a60, 
    prop=0xaa9fc4c0, value=0xa94f5f88 "#383733", error=0x0) at xaml.cpp:4887
        v = 0xa9337480
        rv = true
#19 0x012a4477 in XamlElementInstanceNative::SetProperty (this=0xa94ee970, 
    p=0xb1068820, property=0xa94ee9c0, value=0xa94f5f88 "#383733")
    at xaml.cpp:4336
        prop_name = 0xa93373e0
        owner = 0xaa9f87c0
        dep = 0xaa9fc4c0
#20 0x012a9658 in flush_char_data (p=0xb1068820) at xaml.cpp:1826
No locals.
#21 0x012aae16 in end_element_handler (data=0xb1068820, 
    el=0xa94adc40 "http://schemas.microsoft.com/winfx/2006/xaml/presentation|TextBlock.Foreground") at xaml.cpp:2045
        walk = 0x0
        p = 0xb1068820
#22 0x00d04745 in doContent (parser=<value optimized out>, 
    startTagLevel=<value optimized out>, enc=<value optimized out>, 
    s=0xa9309c83 "</TextBlock.Foreground>\r\n", ' ' <repeats 12 times>, "</TextBlock>\r\n", ' ' <repeats 12 times>, "<TextBlock x:Name=\"subTitle\" Grid.Row=\"1\" Margin=\"0,0,0,0\" FontSize=\"12\" VerticalAlignment=\"Top\" FontFamily=\"Arial\" FontWeight=\"Bold\" Tex"..., end=<value optimized out>, 
    nextPtr=<value optimized out>, haveMore=<value optimized out>)
    at lib/xmlparse.c:2449
        localPart = <value optimized out>
        prefix = <value optimized out>
        uri = <value optimized out>
        len = <value optimized out>
        rawName = 0xa9309c85 "TextBlock.Foreground>\r\n", ' ' <repeats 12 times>, "</TextBlock>\r\n", ' ' <repeats 12 times>, "<TextBlock x:Name=\"subTitle\" Grid.Row=\"1\" Margin=\"0,0,0,0\" FontSize=\"12\" VerticalAlignment=\"Top\" FontFamily=\"Arial\" FontWeight=\"Bold\" TextW"...
        tag = 0xa958baf0
        next = 0xa9309c9a "\r\n", ' ' <repeats 12 times>, "</TextBlock>\r\n", ' ' <repeats 12 times>, "<TextBlock x:Name=\"subTitle\" Grid.Row=\"1\" Margin=\"0,0,0,0\" FontSize=\"12\" VerticalAlignment=\"Top\" FontFamily=\"Arial\" FontWeight=\"Bold\" TextWrapping=\"Wrap\">\r\n    "...
        tok = <value optimized out>
        dtd = 0xaa1d0e00
        eventPP = 0xaf212d50
        eventEndPP = 0xaf212d54
#23 0x00d059a2 in contentProcessor (parser=<value optimized out>, 
    start=<value optimized out>, end=<value optimized out>, 
    endPtr=<value optimized out>) at lib/xmlparse.c:2022
        result = <value optimized out>
#24 0x00d066a3 in doProlog (parser=0xaf212c30, enc=<value optimized out>, 
    s=<value optimized out>, end=<value optimized out>, 
    tok=<value optimized out>, 
    next=0xa9309800 "<UserControl x:Class=\"SilverlightBanner.BannerSlide\"\r\n    xmlns=\"http://schemas.microsoft.com/winfx/2006/xaml/presentation\" \r\n    xmlns:x=\"http://schemas.microsoft.com/winfx/2006/xaml\" \r\n    xmlns:loc"..., nextPtr=<value optimized out>, haveMore=<value optimized out>)
    at lib/xmlparse.c:3904
        role = <value optimized out>
        handleDefault = 1 '\001'
        externalSubsetName = "#"
        atypeCDATA = "CDATA"
        atypeID = "ID"
        atypeIDREF = "IDREF"
        atypeIDREFS = "IDREFS"
        atypeENTITY = "ENTITY"
        atypeENTITIES = "ENTITIES"
        atypeNMTOKEN = "NMTOKEN"
        atypeNMTOKENS = "NMTOKENS"
        notationPrefix = "NOTATION("
        enumValueSep = "|"
        enumValueStart = "("
        dtd = <value optimized out>
        eventPP = 0xaf212d50
        eventEndPP = 0xaf212d54
        quant = <value optimized out>
#25 0x00d07abb in prologProcessor (parser=<value optimized out>, 
    s=<value optimized out>, end=<value optimized out>, 
    nextPtr=<value optimized out>) at lib/xmlparse.c:3635
        next = 0xa9309800 "<UserControl x:Class=\"SilverlightBanner.BannerSlide\"\r\n    xmlns=\"http://schemas.microsoft.com/winfx/2006/xaml/presentation\" \r\n    xmlns:x=\"http://schemas.microsoft.com/winfx/2006/xaml\" \r\n    xmlns:loc"...
        tok = <value optimized out>
#26 0x00cfe53d in XML_ParseBuffer (parser=<value optimized out>, 
    len=<value optimized out>, isFinal=<value optimized out>)
    at lib/xmlparse.c:1573
        start = <value optimized out>
        result = XML_STATUS_OK
#27 0x00cffa95 in XML_Parse (parser=<value optimized out>, 
    s=<value optimized out>, len=<value optimized out>, 
    isFinal=<value optimized out>) at lib/xmlparse.c:1544
        buff = 0x0
#28 0x012aa42f in XamlLoader::HydrateFromString (this=0xa957c1c0, 
    xaml=0xa9306800 "<UserControl x:Class=\"SilverlightBanner.BannerSlide\"\r\n    xmlns=\"http://schemas.microsoft.com/winfx/2006/xaml/presentation\" \r\n    xmlns:x=\"http://schemas.microsoft.com/winfx/2006/xaml\" \r\n    xmlns:loc"..., object=0xbfc959f4, create_namescope=true, element_type=0xbfc959d4, flags=0)
    at xaml.cpp:2491
        start = 0xa9306800 "<UserControl x:Class=\"SilverlightBanner.BannerSlide\"\r\n    xmlns=\"http://schemas.microsoft.com/winfx/2006/xaml/presentation\" \r\n    xmlns:x=\"http://schemas.microsoft.com/winfx/2006/xaml\" \r\n    xmlns:loc"...
        i = 0
        p = 0xaf212c30
        parser_info = 0xb1068820
        res = 0x0
        start = 0xa9306800 "<UserControl x:Class=\"SilverlightBanner.BannerSlide\"\r\n    xmlns=\"http://schemas.microsoft.com/winfx/2006/xaml/presentation\" \r\n    xmlns:x=\"http://schemas.microsoft.com/winfx/2006/xaml\" \r\n    xmlns:loc"...
        prepend = 0x0
        append = 0x0
        inputs = {
          0xa9306800 "<UserControl x:Class=\"SilverlightBanner.BannerSlide\"\r\n    xmlns=\"http://schemas.microsoft.com/winfx/2006/xaml/presentation\" \r\n    xmlns:x=\"http://schemas.microsoft.com/winfx/2006/xaml\" \r\n    xmlns:loc"..., 0x0, 0x0, 0x0}
#29 0x012aa82e in XamlLoader::HydrateFromStringWithError (this=0xa957c1c0, 
    xaml=0xa9306800 "<UserControl x:Class=\"SilverlightBanner.BannerSlide\"\r\n    xmlns=\"http://schemas.microsoft.com/winfx/2006/xaml/presentation\" \r\n    xmlns:x=\"http://schemas.microsoft.com/winfx/2006/xaml\" \r\n    xmlns:loc"..., object=0xbfc959f4, create_namescope=true, element_type=0xbfc959d4, flags=0, 
    error=0xbfc95964) at xaml.cpp:2569
        res = 0x632a0
#30 0x0114c145 in xaml_loader_hydrate_from_string_with_error (
    instance=0xa957c1c0, 
    xaml=0xa9306800 "<UserControl x:Class=\"SilverlightBanner.BannerSlide\"\r\n    xmlns=\"http://schemas.microsoft.com/winfx/2006/xaml/presentation\" \r\n    xmlns:x=\"http://schemas.microsoft.com/winfx/2006/xaml\" \r\n    xmlns:loc"..., obj=0xbfc959f4, create_namescope=true, element_type=0xbfc959d4, flags=0, 
    error=0xbfc95964) at cbinding.cpp:5969
No locals.
#31 0x0391661b in ?? ()
No symbol table info available.
#32 0xa957c1c0 in ?? ()
No symbol table info available.
#33 0xa9306800 in ?? ()
No symbol table info available.
#34 0xbfc959f4 in ?? ()
No symbol table info available.
#35 0x00000001 in ?? ()
No symbol table info available.
#36 0xbfc959d4 in ?? ()
No symbol table info available.
#37 0x00000000 in ?? ()
No symbol table info available.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Chris Campbell 2010-05-07 07:42:14 EDT
Thank you for taking the time to make this bug report.

Unfortunately, crash here happened in the silverlight extension/plug-in which is not provided by Fedora, so unfortunately we cannot help you with it.

Closing as CANTFIX (because that's our situation)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.