Bug 58719 - Boot troubles with IDE
Boot troubles with IDE
Status: CLOSED DUPLICATE of bug 59276
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Beth Uptagrafft
Beth Uptagrafft
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-23 13:46 EST by Michal Jaegermann
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-04 19:37:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2002-01-23 13:46:00 EST
Description of Problem:

With kernel 2.4.9-14a used on UP1100 with the following IDE devices:

hda: Maxtor 31024H2, ATA DISK drive
hdb: IBM-DJNA-370910, ATA DISK drive
hdc: Maxtor 51536H2, ATA DISK drive
hdd: CREATIVE CD5233E, ATAPI CD/DVD-ROM drive

DMA gets turned on (only) for hdb and I am getting immediately
"not ready for a command" and timeouts when trying to access hdb.
I have to pass 'ide=nodma' to be able to boot at all.  Once booted
I see:

hda: 20010816 sectors (10246 MB) w/512KiB Cache, CHS=19852/16/63
hdb: 17803440 sectors (9115 MB) w/1966KiB Cache, CHS=17662/16/63
hdc: 30015216 sectors (15368 MB) w/2048KiB Cache, CHS=29777/16/63

If I am using 2.4.9-14a hacked to boot on UP1500 (see #58498)
or 2.4.17 then for some reasons DMA is not turned on and I can boot.

When using 2.4.17 with Andre Hedrick patches and no manual
interventions I get

hda: 20010816 sectors (10246 MB) w/512KiB Cache, CHS=19852/16/63, UDMA(66)
hdb: 17803440 sectors (9115 MB) w/1966KiB Cache, CHS=17662/16/63, UDMA(33)
hdc: 30015216 sectors (15368 MB) w/2048KiB Cache, CHS=29777/16/63, UDMA(66)

na no problems when booting or using this kernel.  With various kernels
from "ac" series, like 2.4.5-ac8 or 2.4.13-ac8 I even observe

hda: 20010816 sectors (10246 MB) w/512KiB Cache, CHS=19852/16/63, UDMA(66)
hdb: 17803440 sectors (9115 MB) w/1966KiB Cache, CHS=17662/16/63, UDMA(66)
hdc: 30015216 sectors (15368 MB) w/2048KiB Cache, CHS=29777/16/63, UDMA(66)

which is possibly aggresive but still trouble free and disks perform
quite a bit better. :-)
Comment 1 Jeff Wiedemeier 2002-02-04 10:39:47 EST
Michal,

Can you try rebuilding 2.4.9-14a with the ALi15x3 driver enabled to confirm
whether or not this solves the problem on your up1100 (see bug 59276)

Comment 2 Michal Jaegermann 2002-02-04 19:37:06 EST
Turning on ALi15x3 support indeed does solve the problem.  Actually DMA
is turned on automatically for all IDE drives and they perform as expected.
But for a change something new shows up.  See #59312.
Comment 3 Beth Uptagrafft 2002-02-08 15:53:19 EST
Since this issue was resolved by turning on ALi15x3 support (see bug 59276), 
this issue will be marked as a duplicate of 59276, since that case states the 
details on what's needed. The new problem encountered is described in #59312.
 

*** This bug has been marked as a duplicate of 59276 ***

Note You need to log in before you can comment on or make changes to this bug.