Bug 587194 - supertuxkart-0.7 is available
Summary: supertuxkart-0.7 is available
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: supertuxkart
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-29 10:18 UTC by Upstream Release Monitoring
Modified: 2011-01-10 14:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-07 17:03:18 UTC
Type: ---


Attachments (Terms of Use)
specifle patch fixing the build issue with the current master .spec (1.10 KB, patch)
2011-01-07 16:20 UTC, Hans de Goede
no flags Details | Diff

Description Upstream Release Monitoring 2010-04-29 10:18:40 UTC
Latest upstream release: 0.7alpha2
Current version in Fedora Rawhide: 0.6.2
URL: http://sourceforge.net/projects/supertuxkart/files/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring

Comment 1 Gwyn Ciesla 2010-05-10 16:58:52 UTC
Waiting on irrlicht 1.7.x. . .

Comment 2 Upstream Release Monitoring 2010-09-24 10:33:53 UTC
Latest upstream release: 0.7alpha3
Current version in Fedora Rawhide: 0.6.2
URL: http://sourceforge.net/projects/supertuxkart/files/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring

Comment 3 Marcus Nitzschke 2010-12-22 11:38:38 UTC
Supertuxkart 0.7 has been released. It'd be nice to see this in the repos. Thanks :)

Comment 4 Gwyn Ciesla 2010-12-22 14:32:24 UTC
Hmm.  I updated the patches and got it to build, and music won't play and the keyboard won't respond.  I have to switch to a virtual terminal and kill it.

Looks like it might be this:

http://sourceforge.net/tracker/?func=detail&aid=3140875&group_id=202302&atid=981038

I'll try disabling default fullscreen and see if that helps.

Comment 5 Gwyn Ciesla 2010-12-22 15:16:37 UTC
Dropping the 0.6.x addon pack fixes sound and music.  Keyboard still not working.

Comment 6 Gwyn Ciesla 2010-12-22 15:42:51 UTC
Opening the game and turning off fullscreen fixes the keyboard.  I'll try to patch to disable fullscreen by default, since though that should be the default, it's apparently not. . .?

Comment 7 Gwyn Ciesla 2010-12-22 15:50:10 UTC
Ok, nevermind, I got that to work.  Will be in rawhide shortly.

Comment 8 Gwyn Ciesla 2010-12-22 17:11:09 UTC
Running into irrlicht issues in rawhide.  Chasing that down.

Comment 9 Upstream Release Monitoring 2010-12-25 12:21:52 UTC
Latest upstream release: 0.7
Current version in Fedora Rawhide: 0.6.2
URL: http://sourceforge.net/projects/supertuxkart/files/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 10 Hans de Goede 2011-01-07 09:39:44 UTC
Hi Jon,

I just saw that supertuxkart 0.7 final has been released. I also noticed on the supertuxkart blog that there are some bugs in irrlicht 1.7.1, which get exposed by supertuxkart. You need at least irrlicht 1.7.2 for supertuxkart. I see that rawhide has irrlicht 1.7.2 now, but only since December 15th. So make sure you update your irrlicht (if you haven't already) hopefully that will fix the issues you are seeing.

Also if you can share a srpm with what you've so far I can take a look and try to help if you want.

Regards,

Hans

Comment 11 Gwyn Ciesla 2011-01-07 13:09:01 UTC
My builds were failing after that date, and still are.  0.7 final is in git master.

It's using 1.7.2.  The problem is that it's not linking to libIrrXML properly.

http://koji.fedoraproject.org/koji/getfile?taskID=2706826&name=build.log
http://koji.fedoraproject.org/koji/getfile?taskID=2706826&name=root.log

Comment 12 Hans de Goede 2011-01-07 16:20:52 UTC
Created attachment 472257 [details]
specifle patch fixing the build issue with the current master .spec

Hi,

Here is a quick fix for the building issue. I've done 1 test race with a supertuxkart build with this and it seems to work.

The problem with your patch for the same issue, is that LDFLAGS is being overriden from the make cmdline, so patching it in the Makefile won't help.

Also to link in a library you need to use -lfoo not -Lfoo, the -L only adds an additional directory to the linker search path.

Let me know if you could use some more help. I wanted to also take a look
at the fullscreen stuff, but I need to go get the kids from daycare now :)

Regards,

Hans

Comment 13 Gwyn Ciesla 2011-01-07 17:03:18 UTC
Cool, that worked.  Total <facepalm> vis-a-vis -l/-L. :)

If you get a chance to look at fullscreen, that would be great, I'm stumped.  But I understand, my kids come first too. :)

Comment 14 Hans de Goede 2011-01-09 10:29:05 UTC
(In reply to comment #13)
> Cool, that worked.  Total <facepalm> vis-a-vis -l/-L. :)
> 
> If you get a chance to look at fullscreen, that would be great, I'm stumped. 
> But I understand, my kids come first too. :)

Hi,

I just tested and with the final 0.7 release and irrlicht 1.7.2 fullscreen works fine on my machine including the keyboard. I tried changing in both directions, starting with fullscreen enabled, etc. All works.

The problem you're seeing could be an interaction problem with you're window manager, what window manager are you using? I'm using stock gnome with metacity.

Regards,

Hans

Comment 15 Gwyn Ciesla 2011-01-10 14:04:33 UTC
Same here, GNOME/metacity.

Comment 16 Hans de Goede 2011-01-10 14:23:08 UTC
(In reply to comment #15)
> Same here, GNOME/metacity.

Ok, so are you still seeing the keyboard issues you were having earlier?

Regards,

Hans


Note You need to log in before you can comment on or make changes to this bug.