Bug 587338 - valgrind fails with Assertion 'di->bss_size == shdr->sh_size' failed.
Summary: valgrind fails with Assertion 'di->bss_size == shdr->sh_size' failed.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: valgrind (Show other bugs)
(Show other bugs)
Version: 5.5
Hardware: x86_64 Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jakub Jelinek
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-29 16:13 UTC by Jeff Bastian
Modified: 2018-11-14 19:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When testing prelinked programs, valgrind could have crashed due to a segmentation fault due to a failed assertion. This was caused by the prelink utility handling the .bss section incorrectly. This update corrects this assertion so that it no longer fails in the described scenario.
Story Points: ---
Clone Of: 539874
Environment:
Last Closed: 2011-07-21 07:58:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
valgrind dynbss patch (3.91 KB, patch)
2010-04-29 16:13 UTC, Jeff Bastian
no flags Details | Diff
valgrind dynbss patch (3.96 KB, patch)
2010-04-29 16:29 UTC, Jeff Bastian
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1026 normal SHIPPED_LIVE valgrind bug fix update 2011-07-20 15:44:18 UTC

Description Jeff Bastian 2010-04-29 16:13:21 UTC
Created attachment 410155 [details]
valgrind dynbss patch

+++ This bug was initially created as a clone of Bug #539874 +++

valgrind fails with Assertion 'di->bss_size == shdr->sh_size' failed.

Version-Release number of selected component (if applicable):
valgrind-3.5.0-1.el5
libvirt-0.6.3-33.el5

How reproducible:
Always.

Steps to Reproduce:
valgrind -v --leak-check=full --show-reachable=yes --log-file=libvirtd.memcheck /usr/sbin/libvirtd

Actual results:
valgrind: m_debuginfo/readelf.c:1901 (vgModuleLocal_read_elf_debug_info): Assertion 'di->bss_size == shdr->sh_size' failed.
==18688==    at 0x38029D5C: ??? (in /usr/lib64/valgrind/memcheck-amd64-linux)

Expected results:
No crash.

Additional info:
valgrind-3.5.0-dynbss.patch from RHEL 6.0 Beta SRPM fixes the problem.

Comment 1 Jeff Bastian 2010-04-29 16:29:51 UTC
Created attachment 410162 [details]
valgrind dynbss patch

This patch cleans up the line numbers to fix the patch fuzziness.

Comment 4 RHEL Product and Program Management 2010-08-09 19:42:41 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 7 Eliska Slobodova 2011-07-12 14:52:21 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When testing prelinked programs, valgrind could have crashed due to a segmentation fault due to a failed assertion. This was caused by the prelink utility handling the .bss section incorrectly. This update corrects this assertion so that it no longer fails in the described scenario.

Comment 8 Tomas Hoger 2011-07-12 15:06:23 UTC
s/due to a segmentation fault // ?  Possibly s/crashed/exited unexpectedly/ ?

Comment 9 errata-xmlrpc 2011-07-21 07:58:51 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1026.html


Note You need to log in before you can comment on or make changes to this bug.