Bug 58734 - XFree86 does not work on ES45 w/ video card in hoses 1,2, or3
XFree86 does not work on ES45 w/ video card in hoses 1,2, or3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Diego Novillo
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-23 16:09 EST by Jeff Wiedemeier
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 18:45:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
force VGA_EN on invisible PCI host bridge (597 bytes, patch)
2002-01-25 10:22 EST, Jeff Wiedemeier
no flags Details | Diff
corrected version of 101_anyhose (45.11 KB, patch)
2002-02-04 16:47 EST, Jeff Wiedemeier
no flags Details | Diff

  None (edit)
Description Jeff Wiedemeier 2002-01-23 16:09:03 EST
Description of Problem:

XFree86 does not work on ES45 unless the video card is in hose 0 (i.e. hoses 1,
2, and 3 don't work)

Version-Release number of selected component (if applicable):

4.1.0-8

How Reproducible:

Very

Steps to Reproduce:
1. Put video card in hose 1, 2, or 3 (hose can be checked with show config from
SRM console)
2. Try to use XFree86

Actual Results:

No device found

Expected Results:

X display

Additional Information:
	
Can be fixed by applying XFree86 patches sent previously
Comment 1 Mike A. Harris 2002-01-23 17:51:22 EST
The latest XFree86 build internally is 4.1.0-15, which does contain
the patches that were sent to me.

I do not think people are pulling their packages from my latest builds.

XFree86-4.1.0-8 is ancient.
Comment 2 Jeff Wiedemeier 2002-01-25 10:20:55 EST
There is one additional patch (beyond those already submitted) to allow XFree86
to work properly with a video card (tested with AGP Radeon) in hose 1,2,or 3
with the configuration file generated by Xconfigurator. This patch forces VGA_EN
for invisible pci host bridges (as is already done for probed pci host bridges)
to allow proper defaulting of the busid so that in a single video card
configuration, a single device section without a BusID can be properly assigned.

Patch will be attached.
Comment 3 Jeff Wiedemeier 2002-01-25 10:22:07 EST
Created attachment 43474 [details]
force VGA_EN on invisible PCI host bridge
Comment 4 Diego Novillo 2002-01-29 10:35:41 EST
Fixed in upcoming release.
Comment 5 Jeff Wiedemeier 2002-02-04 16:47:01 EST
The previously submitted version of the 101_anyhose patch inadvertently broke
sparse memory systems. A corrected patch will be attached -- please apply the
corrected patch instead of the original one.
Comment 6 Jeff Wiedemeier 2002-02-04 16:47:50 EST
Created attachment 44457 [details]
corrected version of 101_anyhose
Comment 7 Diego Novillo 2002-02-06 18:45:14 EST
Patch submitted to mharris@redhat.com for consideration.
Comment 8 Beth Uptagrafft 2002-03-13 09:52:14 EST
I'm closing this case because it was fixed in the Feb 22 delivery.  Please let 
us know if you still see any problems with this issue.

Note You need to log in before you can comment on or make changes to this bug.