Bug 587459 - Misleading error message whilst performing LVM modification during setup
Misleading error message whilst performing LVM modification during setup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: David Cantrell
Martin Banas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-29 20:00 EDT by Chris Lloyd
Modified: 2010-07-02 16:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.35-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 16:48:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lloyd 2010-04-29 20:00:16 EDT
Description of problem:

When editing the default logical volumes, increasing a volume's size beyond what is available in the volume group causes an misleadingly worded error message.

Version-Release number of selected component (if applicable):
Red Hat Enterprise 6 Beta

Steps to Reproduce:
1. Navigate to the partition configuration screen
2. Edit the automatically created volume group (vg_hostname1 by default)
3. Select lv_root
4. Attempt to increase the size of the volume, click OK
  
Actual results:
Message: "The logical volumes you have configured require 65536MB but the volume group only has 476432MB."

Expected results:
The message should indicate that the problem is the space in the VG is too low for all these LVs to be created, rather than implying there is 476GB free for the LV. The message also indicates it thinks 65536MB is needed in total, but that is only the size of the single LV being edited. The message is wrong either way.
Comment 2 RHEL Product and Program Management 2010-04-29 21:33:00 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Martin Banas 2010-05-19 03:38:55 EDT
Hello, retested on build RHEL6.0-20100512.0, anaconda-13.21.39-1.el6. The error message is now:

The size entered for this logical volume (52000 MB) combined with the size of the other logical volume(s) exceeds the size of the volume group (183804 MB). Please make the volume group larger or make the logical volume smaller.

This seems correct to me, closing as VERIFIED.
Comment 6 releng-rhel@redhat.com 2010-07-02 16:48:09 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.