Bug 58750 - bind initscript kills itself on reload
bind initscript kills itself on reload
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-23 20:37 EST by Need Real Name
Modified: 2014-01-21 17:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 17:51:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-23 20:37:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Problem is with running:  /etc/rc.d/init.d/named reload

If rndc isn't working (and it doesn't, as distributed) then it falls
back to running "killall -HUP named."  This ends up killing the initscript
itself, since it is called "named."


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make sure rndc is broken (it is by default.)
2. As root run: /etc/rc.d/init.d/named reload
3.
	

Actual Results:  Script dies with a "Hangup" error.  (SIGHUP received)

Expected Results:  It should work.

Additional info:

Proposed solution would be to replace

    /usr/bin/killall -HUP named

with:

    kill -HUP `cat /var/run/named.pid`

Note You need to log in before you can comment on or make changes to this bug.