Bug 587650 - install hangs under Virtualbox
install hangs under Virtualbox
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
athlon Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks: 846704
  Show dependency treegraph
 
Reported: 2010-04-30 09:25 EDT by Wade Hampton
Modified: 2013-11-18 06:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 06:51:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Hampton 2010-04-30 09:25:07 EDT
Description of problem:  

Attempting to install RHEL6 Beta1 under Virtualbox.  Install formats disk and starts loading packages.  After a few minutes and after loading a few packages, install hangs.  Top shows Virtual box is using 100% of the CPU and 51% of memory.

Version-Release number of selected component (if applicable):  6.0 Beta 1


How reproducible:  Tried 3 times.  Hung each time.


Steps to Reproduce:
1. Setup computer (Athlon, CentOS 5.4 i386 + updates)
2. Install virtualbox (latest via RPM for RHEL/CentOS 5)
3. Download RHEL 6 Beta and try to install 
  
Actual results:  Install hangs and virtual box uses 100% of the CPU. 


Expected results:  Successful install.


Additional info:

On the same computer with same Virtual Box, I successfully loaded 
both Fedora 12 and Fedora 13 beta.

Hardware info:
   AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
   MemTotal:      2009272 kB
   400G SATA disk
O/S Info:
   CentOS release 5.4 (Final)
   VirtualBox-3.1-3.1.6_59338_rhel5-1
   2.6.18-164.15.1.el5 #1 SMP
Virtual Box Setup:
   OS Type:  Red Hat
   Base Memory: 945 MB
   VT-x/AMD-V:  Enabled  [PAE enabled]
   Video Memory:  32 MB
   3D Acceleration:  Enabled
   Adapter 1:  PCnet-FAST III (Bridged adapter, eth1)

Notes:
1. I had to enable PAE/NX on the processor tab because the 
   install kernel would not boot!
2. Disk is a virtual disk file, not hardware.
3. Source is an ISO image on the hard disk.
4. RHEL install type is software development workstation, 
   using default disk partitioning and package set.
Comment 2 Chris Lumens 2010-04-30 10:15:36 EDT
I need more debugging information before I can even begin to speculate on what might be going on.  What's the nature of the hang?  Can you switch VTs?  If so, can you attach /tmp/syslog, /tmp/anaconda.log, /tmp/program.log, and the output of ps -ef to this bug report?
Comment 3 RHEL Product and Program Management 2010-04-30 10:46:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Stephan Wiesand 2010-04-30 11:45:20 EDT
FWIW, I had no problem installing the beta (x86_64) from the DVD ISO image on a Snow Leopard host under VirtualBox 3.1.6.
Comment 5 Wade Hampton 2010-04-30 11:50:38 EDT
The hang is that the install seems to stop for a very long time.  I gave up
after about 1/2 hour or so with no change.  The last time I tried, it hung when
installing glibc.  Each time it has hung at a different part.  On the host
machine, the CPU goes to 100% and the memory to 51%.  

I am using the GUI installer. However, I can't switch VTs as switching VTs will
switch me to another VT on the host machine (CentOS 5.4) and not the virtual
machine. Is there a key sequence to switch VTs in the VM?  

As I can't switch VTs I can't access the relevant log files.  Is there a way of
mounting a Virtualbox disk image so I could directly access these files in the
disk image? I am only recently using Vbox (lots experience w/ VMWare 10 years
ago).  Any help reading the disks would be most appreciated.

I am repeating the install, once again in GUI mode. 
BTW, both the host O/S and the target O/S are i386.
Comment 6 Chris Lumens 2010-04-30 11:58:07 EDT
> I am using the GUI installer. However, I can't switch VTs as switching VTs will
> switch me to another VT on the host machine (CentOS 5.4) and not the virtual
> machine. Is there a key sequence to switch VTs in the VM?  

Varies by program.  With qemu, I hit ctrl-alt-2, type in "sendkey ctrl-alt-f2", hit ctrl-alt-1, and I'm at tty2 in the VM.
Comment 7 Wade Hampton 2010-04-30 15:20:57 EDT
Update:  I couldn't find a key sequence like that for qemu for Virtualbox (Google search and a scan of the Vbox docs).  Install has been frozen on valgrind, package 442 of 1472. From TOP on my host:  

  Cpu0  :  2.0%us,  0.3%sy,  0.0%ni, 97.7%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
  Cpu1  :  7.3%us, 91.0%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.3%hi,  1.3%si,  0.0%st

and:
  
   PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND 
   15   0 1138m 1.0g  19m S 99.1 51.4 212:24.01 VirtualBox

Could this be hang in a system call?
Comment 8 Chris Lumens 2010-04-30 16:28:27 EDT
Hard to tell.  It certainly could be.  It could be an anaconda problem or a Virtualbox problem.   This URL looks like it describes how to switch VTs:

http://www.linuxquestions.org/questions/linux-general-1/switching-virtual-terminals-within-virtualbox-662935/

Is that not helpful?
Comment 9 Wade Hampton 2010-05-03 10:37:42 EDT
I verified I could use Right Ctrl+<function key> to access the VTs on my Virtualbox system.  However, when the install hangs, I can't access the VTs nor will the mouse in the VM move.  

I also tried Virtual Box 3.2 beta 1 and it has the same problems.

Next test is to try text-mode install on this VM.
Comment 10 Wade Hampton 2010-05-03 13:14:12 EDT
Text mode install worked (VBox 3.2 beta 1).  All Vbox settings were identical between my previous attempts and this successful text-mode install.  

Are there any further tests that RedHat would like me to perform?
Comment 11 Wade Hampton 2010-05-06 12:16:19 EDT
Successful load.  The following seem to be the issues causing install to hang:

1) If IO APIC is enabled, install seems to hang most of the time:
  Settings->System->Motherboard
    enable IO APIC 

2) If memory usage is close to 1/2 of the base O/S memory install
   seems to hang even if the IO APIC is turned off.
      795M worked always
      956M failed always

Both times, the system experienced the same failure,
Comment 12 RHEL Product and Program Management 2010-07-15 10:39:59 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 13 RHEL Product and Program Management 2011-10-07 11:01:03 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 14 Jes Sorensen 2013-11-18 06:51:48 EST
There has been no activity on this one for 3.5 years - closing

If you see this against a recent version of RHEL, please file a new bugzilla

Thanks,
Jes

Note You need to log in before you can comment on or make changes to this bug.