Bug 58776 - Cannot upgrade package
Cannot upgrade package
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-libs (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-24 08:04 EST by Mario Mikocevic
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 08:04:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Mikocevic 2002-01-24 08:04:37 EST
Description of Problem:
Latest gnome-libs has some strange dependencies of db1 so it cannot be
upgraded.

Version-Release number of selected component (if applicable):
# rpm -qa | grep db1
db1-1.85-7
# rpm -qa | grep gnome-libs
gnome-libs-1.4.1.2.90-3


How Reproducible:
Always


Steps to Reproduce:
1. rpm -Fvh gnome-libs*
2. 
3. 

Actual Results:
# rpm -Fvh gnome-libs*                 
Preparing...                ########################################### [100%]
file /usr/bin/db1_dump185 from install of gnome-libs-1.4.1.2.90-4 conflicts with
file from package db1-1.85-7
file /usr/lib/libdb1.so.2 from install of gnome-libs-1.4.1.2.90-4 conflicts with
file from package db1-1.85-7


Expected Results:
All done well.

Additional Information:
db1 can't be erased because old gnome-libs-1.4.1.2.90-3 depends on it.
Comment 1 Havoc Pennington 2002-01-24 10:04:04 EST
The db1 package will be removed in the end. Current bug is that some other
packages require db1 so you can't rpm -e db1. I'm going to go ahead and close
the bug since people are in the process of fixing it and it's very obvious it's
broken.

Note You need to log in before you can comment on or make changes to this bug.