Bug 587872 - cyrus-imapd package not available for RHEL6
cyrus-imapd package not available for RHEL6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.0
All Linux
medium Severity high
: rc
: ---
Assigned To: Michal Hlavinka
qe-baseos-daemons
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-01 05:52 EDT by Uwe Beck
Modified: 2010-11-10 17:07 EST (History)
18 users (show)

See Also:
Fixed In Version: cyrus-imapd-2.3.16-5.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 17:07:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uwe Beck 2010-05-01 05:52:04 EDT
Description of problem:

cyrus-imapd package is not available for RHEL6

How reproducible:

cyrus-imapd rpms are not available on DVD or optional repository

Expected results:

cyrus-imapd is really an enterprise IMAP server. No problems with shares folder
and sieve (like other imap server) with different mail clients. 
Since version 2.3.* at RHEL5 there is replication included and it works perfect.
 
cyrus-imapd is not listed at:
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6-Beta/html/Beta_Release_Notes/apcs04.html

This means cyrus-imapd is part of RHEL6.

Additional info:

cyrus-imapd and squirrelmail are a basement for our businesses (also with RHEL6).
Comment 2 RHEL Product and Program Management 2010-05-01 07:14:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Karanbir Singh 2010-05-02 16:41:47 EDT
Just want to add another comment about Cyrus-IMAPD. Its a great ( the only ? ) really capable mailstore server, with a great set of features. Dovecot can neither scale as far as cyrus, not compete in feature terms - like server side search, shared folders, replicated mail store, high availability, quota management and policy based notification support.

While dovecot does have much of this functionality, it usually involves using extra, buggy plugins that neither compare with cyrus on performance nor in stability.
Comment 5 Jason McCormick 2010-06-01 17:28:56 EDT
This is an "Me Too" for the (re)inclusion of Cyrus IMAP in RHEL.  We use Cyrus IMAP extensively on RHEL5 now.
Comment 8 Vilius Šumskas 2010-06-08 10:05:48 EDT
Same here. Cyrus-imapd is a must for big email environments. Please add!
Comment 12 Uwe Beck 2010-07-04 08:17:44 EDT
Fixed in version cyrus-imapd-2.3.16-5.el6 since 2010-06-10 02:35:28 EDT.

RHEL6.0-20100622.1-Server-*-DVD1.iso (Beta2) is available now.
cyrus-imapd-2.3.16-5.el6 rpms are not available on DVD or optional repository.

Is there a link for download?
Comment 13 Michal Hlavinka 2010-07-08 10:14:02 EDT
(In reply to comment #12)
> Fixed in version cyrus-imapd-2.3.16-5.el6 since 2010-06-10 02:35:28 EDT.
> 
> RHEL6.0-20100622.1-Server-*-DVD1.iso (Beta2) is available now.
> cyrus-imapd-2.3.16-5.el6 rpms are not available on DVD or optional repository.

package cyrus-imapd-2.3.16-6.el6 is included in compose RHEL6.0-20100701.0 so that your iso is too old

> Is there a link for download?    

I'm not sure if there is publicly accessible link, most probably you'll have to wait until yum repository contains them.
Comment 14 Niels de Vos 2010-08-20 06:06:22 EDT
(In reply to comment #13)
> (In reply to comment #12)
> > Fixed in version cyrus-imapd-2.3.16-5.el6 since 2010-06-10 02:35:28 EDT.
> > 
> > Is there a link for download?    
> 
> I'm not sure if there is publicly accessible link, most probably you'll have to
> wait until yum repository contains them.

When you login on Red Hat Network, you should be able to reach the package on this URL:
- https://rhn.redhat.com/rhn/software/packages/details/Overview.do?pid=546031
Comment 15 Alexander Todorov 2010-08-20 14:24:52 EDT
Available in snap #12.

[root@ibm-x3950m2-02 6]# pwd
/mnt/redhat/rel-eng/RHEL6.0-20100818.0/6

[root@ibm-x3950m2-02 6]# find -name "cyrus-imapd*"
./Server/i386/os/Packages/cyrus-imapd-utils-2.3.16-6.el6.i686.rpm
./Server/i386/os/Packages/cyrus-imapd-2.3.16-6.el6.i686.rpm
./Server/i386/debug/cyrus-imapd-debuginfo-2.3.16-6.el6.i686.rpm
./Server/source/SRPMS/cyrus-imapd-2.3.16-6.el6.src.rpm
./Server/optional/i386/os/Packages/cyrus-imapd-devel-2.3.16-6.el6.i686.rpm
./Server/optional/s390x/os/Packages/cyrus-imapd-devel-2.3.16-6.el6.s390.rpm
./Server/optional/s390x/os/Packages/cyrus-imapd-devel-2.3.16-6.el6.s390x.rpm
./Server/optional/s390x/debug/cyrus-imapd-debuginfo-2.3.16-6.el6.s390.rpm
./Server/optional/x86_64/os/Packages/cyrus-imapd-devel-2.3.16-6.el6.i686.rpm
./Server/optional/x86_64/os/Packages/cyrus-imapd-devel-2.3.16-6.el6.x86_64.rpm
./Server/optional/x86_64/debug/cyrus-imapd-debuginfo-2.3.16-6.el6.i686.rpm
./Server/optional/ppc64/os/Packages/cyrus-imapd-devel-2.3.16-6.el6.ppc.rpm
./Server/optional/ppc64/os/Packages/cyrus-imapd-devel-2.3.16-6.el6.ppc64.rpm
./Server/optional/ppc64/debug/cyrus-imapd-debuginfo-2.3.16-6.el6.ppc.rpm
./Server/s390x/os/Packages/cyrus-imapd-utils-2.3.16-6.el6.s390x.rpm
./Server/s390x/os/Packages/cyrus-imapd-2.3.16-6.el6.s390x.rpm
./Server/s390x/debug/cyrus-imapd-debuginfo-2.3.16-6.el6.s390x.rpm
./Server/ppc64/os/Packages/cyrus-imapd-utils-2.3.16-6.el6.ppc64.rpm
./Server/ppc64/os/Packages/cyrus-imapd-2.3.16-6.el6.ppc64.rpm
./Server/ppc64/debug/cyrus-imapd-debuginfo-2.3.16-6.el6.ppc64.rpm
./Server/x86_64/os/Packages/cyrus-imapd-2.3.16-6.el6.x86_64.rpm
./Server/x86_64/os/Packages/cyrus-imapd-utils-2.3.16-6.el6.x86_64.rpm
./Server/x86_64/debug/cyrus-imapd-debuginfo-2.3.16-6.el6.x86_64.rpm
./Workstation/i386/os/Packages/cyrus-imapd-2.3.16-6.el6.i686.rpm
./Workstation/i386/os/Packages/cyrus-imapd-utils-2.3.16-6.el6.i686.rpm
./Workstation/i386/debug/cyrus-imapd-debuginfo-2.3.16-6.el6.i686.rpm
./Workstation/source/SRPMS/cyrus-imapd-2.3.16-6.el6.src.rpm
./Workstation/optional/i386/os/Packages/cyrus-imapd-devel-2.3.16-6.el6.i686.rpm
./Workstation/optional/x86_64/os/Packages/cyrus-imapd-devel-2.3.16-6.el6.i686.rpm
./Workstation/optional/x86_64/os/Packages/cyrus-imapd-devel-2.3.16-6.el6.x86_64.rpm
./Workstation/optional/x86_64/debug/cyrus-imapd-debuginfo-2.3.16-6.el6.i686.rpm
./Workstation/x86_64/os/Packages/cyrus-imapd-2.3.16-6.el6.x86_64.rpm
./Workstation/x86_64/os/Packages/cyrus-imapd-utils-2.3.16-6.el6.x86_64.rpm
./Workstation/x86_64/debug/cyrus-imapd-debuginfo-2.3.16-6.el6.x86_64.rpm
./source/SRPMS/cyrus-imapd-2.3.16-6.el6.src.rpm
Comment 16 Niels de Vos 2010-08-29 04:52:19 EDT
(In reply to comment #14)
> (In reply to comment #13)
> > (In reply to comment #12)
> > > Fixed in version cyrus-imapd-2.3.16-5.el6 since 2010-06-10 02:35:28 EDT.
> > > 
> > > Is there a link for download?    
> > 
> > I'm not sure if there is publicly accessible link, most probably you'll have to
> > wait until yum repository contains them.
> 
> When you login on Red Hat Network, you should be able to reach the package on
> this URL:
> - https://rhn.redhat.com/rhn/software/packages/details/Overview.do?pid=546031

Unfortunately the RHEL6-Beta channels do not contain any packages any more at the moment. This can be verified when checking the details of the channel:
- https://rhn.redhat.com/network/software/channels/details.pxt?cid=10156

Summary:  	Red Hat Enterprise Linux Server Beta (v. 6 for 64-bit AMD64 / Intel64)
Description: 	Red Hat Enterprise Linux - Server components Beta (v. 6 for 64-bit AMD64 / Intel64)
Label: 	rhel-x86_64-server-6-beta
Last Modified: 	2010-08-24 17:08:34 PDT
Channel Entitlement Name: 	Red Hat Enterprise Linux beta (core server)
Parent Channel: 	(none)
Architecture: 	x86_64
Packages: 	0


I guess we need to wait until the packages are available again...
Comment 18 releng-rhel@redhat.com 2010-11-10 17:07:57 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.