Bug 58799 - mkswap > 2097159 blocks reports negative size
mkswap > 2097159 blocks reports negative size
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Tromey
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-24 15:46 EST by Jeff Wiedemeier
Modified: 2014-08-11 01:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-30 19:28:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Wiedemeier 2002-01-24 15:46:18 EST
Description of Problem:

Running mkswap on a partition larger than 2097159 blocks (or specifying a size
larger than 2097159 blocks on the mkswap command line with a partition large
enough to handle it) reports the swap size created as a negative number. The
swap is actually set up correctly (and reports the correct size in use after
swapon) but mkswap reports the size as negative

Version-Release number of selected component (if applicable):

Red Hat Linux release 7.1.90 (Roswell)
util-linux-2.11f-17

How Reproducible:

very

Steps to Reproduce:
1. Create a large swap partition with fdisk (4G is plenty) 
2. mkswap on the newly created partition 

Actual Results:

Swap is created, but the size is reported as a negative number

Expected Results:

Create swap and report correct size

Additional Information:
Comment 1 Elliot Lee 2002-01-29 15:16:58 EST
Patch going into util-linux-2.11n-3
Comment 2 Tom Tromey 2002-01-30 19:28:29 EST
I've put Elliot's fix into 2.11f-18.
It will appear in the release candidate.
Comment 3 Beth Uptagrafft 2002-03-13 09:59:34 EST
I'm closing this case because it was fixed in the Feb 22 delivery.  Please let 
us know if you still see any problems with this issue.

Note You need to log in before you can comment on or make changes to this bug.