Bug 588001 - [abrt] crash in yum-utils-1.1.25-1.fc12
Summary: [abrt] crash in yum-utils-1.1.25-1.fc12
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils   
(Show other bugs)
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a32c74a8
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-02 04:45 UTC by Jayrome
Modified: 2014-01-21 23:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-02 05:26:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.35 KB, text/plain)
2010-05-02 04:45 UTC, Jayrome
no flags Details

Description Jayrome 2010-05-02 04:45:42 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python -tt /usr/bin/yum-builddep akmod-nvidia
component: yum-utils
executable: /usr/bin/yum-builddep
kernel: 2.6.31.12-174.2.22.fc12.x86_64
package: yum-utils-1.1.25-1.fc12
release: Fedora release 12 (Constantine)
uuid: 1a00a3c0

backtrace
-----
Summary: TB1a00a3c0 yum-builddep:40:_best_convert_pkg2srcpkgs:AttributeError: Values instance has no attribute 'source'

Traceback (most recent call last):
  File "/usr/bin/yum-builddep", line 196, in <module>
    util = YumBuildDep()
  File "/usr/bin/yum-builddep", line 64, in __init__
    self.main()
  File "/usr/bin/yum-builddep", line 93, in main
    self.get_build_deps(opts)
  File "/usr/bin/yum-builddep", line 169, in get_build_deps
    toActOn.extend(_best_convert_pkg2srcpkgs(self, opts, newpkg))
  File "/usr/bin/yum-builddep", line 40, in _best_convert_pkg2srcpkgs
    if not opts.source or pkg.arch == 'src':
AttributeError: Values instance has no attribute 'source'

Local variables in innermost frame:
self: <__main__.YumBuildDep object at 0xfe6c10>
pkg: <YumAvailablePackageSqlite : akmod-nvidia-190.53-1.fc12.x86_64 (0x7563450)>
opts: <Values at 0x11c83f8: {'skipbroken': None, 'verbose': None, 'errorlevel': None, 'color': None, 'repos': [], 'conffile': '/etc/yum/yum.conf', 'exclude': [], 'enableplugins': [], 'tolerant': None, 'cacheonly': None, 'disableplugins': [], 'sleeptime': None, 'version': None, 'obsoletes': None, 'debuglevel': None, 'disableexcludes': [], 'nogpgcheck': None, 'showdupesfromrepos': None, 'assumeyes': None, 'disablepresto': False, 'installroot': None, 'quiet': None, 'exclude_bin': False, 'remove_leaves': False, 'noplugins': None}>

Comment 1 Jayrome 2010-05-02 04:45:45 UTC
Created attachment 410754 [details]
File: backtrace

Comment 2 James Antill 2010-05-02 05:26:04 UTC
I think this is fixed already. Try again with the latest yum-utils.

 Run: yum update yum-utils


Note You need to log in before you can comment on or make changes to this bug.