Bug 588017 - eclipse.x86_64 does not search in /usr/lib64
eclipse.x86_64 does not search in /usr/lib64
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-02 03:51 EDT by Kim Bisgaard
Modified: 2010-08-23 15:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 15:28:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kim Bisgaard 2010-05-02 03:51:40 EDT
Description of problem:
Eclipse cannot find librarys installed in /usr/lib64

Version-Release number of selected component (if applicable):
eclipse-platform-3.5.2-1.fc13.x86_64              
eclipse-subclipse-1.6.8-1.fc13.noarch  
subversion-javahl-1.6.9-2.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
1. start eclipse
2. setup svn based project
3. goto project->properties->subversion
  
Actual results:
Failed to load JavaHL Library.
These are the errors that were encountered:
no libsvnjavahl-1 in java.library.path
no svnjavahl-1 in java.library.path
no svnjavahl in java.library.path
java.library.path = /usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/amd64:/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/../lib/amd64:/usr/lib64/xulrunner-1.9.2:/usr/java/packages/lib/amd64:/lib:/usr/lib

Expected results:
Info about subversion repo

Additional info:
rpm -ql subversion-javahl.x86_64
/usr/lib64/libsvnjavahl-1.la
/usr/lib64/libsvnjavahl-1.so
/usr/lib64/libsvnjavahl-1.so.0
/usr/lib64/libsvnjavahl-1.so.0.0.0
/usr/share/java/svn-javahl.jar
Comment 1 Andrew Overholt 2010-05-03 09:37:20 EDT
This works for me on F-12 x86_64.  I'll set up an F-13 box to see what changed.

Have you tried mv ~/.eclipse{,.temporarilymovingforbug588017} and re-launched eclipse to see if it helps?  Or maybe a new workspace location (-data switch)?
Comment 2 Kim Bisgaard 2010-05-03 15:42:02 EDT
Yes now I have - but I get the same error, when trying to create a new project in the empty workspace.

I can get it to work by editing /usr/lib64/eclipse/eclipse.ini to include a line with:
-Djava.library.path=/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/amd64:/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/../lib/amd64:/usr/lib64/xulrunner-1.9.2:/usr/java/packages/lib/amd64:/usr/lib64:/lib:/usr/lib
Comment 3 Andrew Overholt 2010-05-03 15:44:59 EDT
Does it work out of the box if you use OpenJDK?
Comment 4 Kim Bisgaard 2010-05-03 16:05:46 EDT
Yes now I have - but I get the same error, when trying to create a new project in the empty workspace.

I can get it to work by editing /usr/lib64/eclipse/eclipse.ini to include a line with:
-Djava.library.path=/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/amd64:/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/../lib/amd64:/usr/lib64/xulrunner-1.9.2:/usr/java/packages/lib/amd64:/usr/lib64:/lib:/usr/lib
Comment 5 Kim Bisgaard 2010-05-03 16:07:30 EDT
Good question -- wait a couple of day while I install virtualization, download install media, test -- please.
Comment 6 Kim Bisgaard 2010-05-06 15:12:35 EDT
(In reply to comment #3)
> Does it work out of the box if you use OpenJDK?    

Yes it does.

with exact same versions.
Comment 7 Andrew Overholt 2010-05-06 15:38:12 EDT
We can't really support the Sun JDK since it's not Free software and not in Fedora.  Sorry.

Note You need to log in before you can comment on or make changes to this bug.