Bug 588017 - eclipse.x86_64 does not search in /usr/lib64
Summary: eclipse.x86_64 does not search in /usr/lib64
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-02 07:51 UTC by Kim Bisgaard
Modified: 2010-08-23 19:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 19:28:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kim Bisgaard 2010-05-02 07:51:40 UTC
Description of problem:
Eclipse cannot find librarys installed in /usr/lib64

Version-Release number of selected component (if applicable):
eclipse-platform-3.5.2-1.fc13.x86_64              
eclipse-subclipse-1.6.8-1.fc13.noarch  
subversion-javahl-1.6.9-2.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
1. start eclipse
2. setup svn based project
3. goto project->properties->subversion
  
Actual results:
Failed to load JavaHL Library.
These are the errors that were encountered:
no libsvnjavahl-1 in java.library.path
no svnjavahl-1 in java.library.path
no svnjavahl in java.library.path
java.library.path = /usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/amd64:/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/../lib/amd64:/usr/lib64/xulrunner-1.9.2:/usr/java/packages/lib/amd64:/lib:/usr/lib

Expected results:
Info about subversion repo

Additional info:
rpm -ql subversion-javahl.x86_64
/usr/lib64/libsvnjavahl-1.la
/usr/lib64/libsvnjavahl-1.so
/usr/lib64/libsvnjavahl-1.so.0
/usr/lib64/libsvnjavahl-1.so.0.0.0
/usr/share/java/svn-javahl.jar

Comment 1 Andrew Overholt 2010-05-03 13:37:20 UTC
This works for me on F-12 x86_64.  I'll set up an F-13 box to see what changed.

Have you tried mv ~/.eclipse{,.temporarilymovingforbug588017} and re-launched eclipse to see if it helps?  Or maybe a new workspace location (-data switch)?

Comment 2 Kim Bisgaard 2010-05-03 19:42:02 UTC
Yes now I have - but I get the same error, when trying to create a new project in the empty workspace.

I can get it to work by editing /usr/lib64/eclipse/eclipse.ini to include a line with:
-Djava.library.path=/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/amd64:/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/../lib/amd64:/usr/lib64/xulrunner-1.9.2:/usr/java/packages/lib/amd64:/usr/lib64:/lib:/usr/lib

Comment 3 Andrew Overholt 2010-05-03 19:44:59 UTC
Does it work out of the box if you use OpenJDK?

Comment 4 Kim Bisgaard 2010-05-03 20:05:46 UTC
Yes now I have - but I get the same error, when trying to create a new project in the empty workspace.

I can get it to work by editing /usr/lib64/eclipse/eclipse.ini to include a line with:
-Djava.library.path=/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/amd64:/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/../lib/amd64:/usr/lib64/xulrunner-1.9.2:/usr/java/packages/lib/amd64:/usr/lib64:/lib:/usr/lib

Comment 5 Kim Bisgaard 2010-05-03 20:07:30 UTC
Good question -- wait a couple of day while I install virtualization, download install media, test -- please.

Comment 6 Kim Bisgaard 2010-05-06 19:12:35 UTC
(In reply to comment #3)
> Does it work out of the box if you use OpenJDK?    

Yes it does.

with exact same versions.

Comment 7 Andrew Overholt 2010-05-06 19:38:12 UTC
We can't really support the Sun JDK since it's not Free software and not in Fedora.  Sorry.


Note You need to log in before you can comment on or make changes to this bug.