Bug 588083 - wi-fi on T60
wi-fi on T60
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-02 11:07 EDT by Tomas Henzl
Modified: 2010-07-13 04:44 EDT (History)
9 users (show)

See Also:
Fixed In Version: kernel-2.6.32.13-120.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 04:44:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages file when issue is occurring (26.48 KB, text/plain)
2010-05-19 15:23 EDT, Tamas Kalman
no flags Details

  None (edit)
Description Tomas Henzl 2010-05-02 11:07:17 EDT
Hi Stando,

below is dmesg (shortened) from what happens when the wifi connection 
on my T60 drops.

I think that it fails when the load is higher.

rmmod/modprobe iwl3945 brings it back to life.

dmesg:
wlan0: no IPv6 routers present
No probe response from AP 00:24:8c:97:41:f4 after 500ms, disconnecting.
iwl3945 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
iwl3945 0000:03:00.0: Error setting new configuration (-110).
iwl3945 0000:03:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
iwl3945 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
iwl3945 0000:03:00.0: Error setting new configuration (-110).
iwl3945 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
iwl3945 0000:03:00.0: Error setting new configuration (-110).
iwl3945 0000:03:00.0: Error sending REPLY_TX_PWR_TABLE_CMD: time out after 500ms.
 connection3:0: ping timeout of 5 secs expired, recv timeout 5, last rx 4298985205, last ping 4298990205, now 4298995205
 connection3:0: detected conn error (1011)
iwl3945 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
iwl3945 0000:03:00.0: Error setting new configuration (-110).
iwl3945 0000:03:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
iwl3945 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
..............
iwl3945 0000:03:00.0: Error setting new configuration (-110).
iwl3945 0000:03:00.0: No space for Tx
iwl3945 0000:03:00.0: Error sending REPLY_SCAN_CMD: enqueue_hcmd failed: -28
iwl3945 0000:03:00.0: No space for Tx
iwl3945 0000:03:00.0: Error sending REPLY_RXON: enqueue_hcmd failed: -28
iwl3945 0000:03:00.0: Error setting new configuration (-28).
iwl3945 0000:03:00.0: No space for Tx
iwl3945 0000:03:00.0: Error sending REPLY_RXON: enqueue_hcmd failed: -28
iwl3945 0000:03:00.0: Error setting new configuration (-28).
iwl3945 0000:03:00.0: No space for Tx
iwl3945 0000:03:00.0: Error sending REPLY_TX_PWR_TABLE_CMD: enqueue_hcmd failed: -28
iwl3945 0000:03:00.0: PCI INT A disabled
iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26kds
iwl3945: Copyright(c) 2003-2009 Intel Corporation
iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwl3945 0000:03:00.0: setting latency timer to 64
iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG
iwl3945 0000:03:00.0: irq 31 for MSI/MSI-X
phy1: Selected rate control algorithm 'iwl-3945-rs'
iwl3945 0000:03:00.0: firmware: requesting iwlwifi-3945-2.ucode
iwl3945 0000:03:00.0: loaded firmware version 15.32.2.9
Registered led device: iwl-phy1::radio
Registered led device: iwl-phy1::assoc
Registered led device: iwl-phy1::RX
Registered led device: iwl-phy1::TX
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: deauthenticating from 00:24:8c:97:41:f4 by local choice (reason=3)
wlan0: direct probe to AP 00:24:8c:97:41:f4 (try 1)
wlan0: direct probe responded
wlan0: authenticate with AP 00:24:8c:97:41:f4 (try 1)
wlan0: authenticated
wlan0: associate with AP 00:24:8c:97:41:f4 (try 1)
wlan0: RX AssocResp from 00:24:8c:97:41:f4 (capab=0x411 status=0 aid=2)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready


uname -r
2.6.32.11-99.fc12.x86_64
Comment 1 Kyryl Bilokurov 2010-05-06 16:59:46 EDT
Looks like it is also present in FC13, submitted the https://bugzilla.redhat.com/show_bug.cgi?id=589777
Comment 2 Tamas Kalman 2010-05-19 15:23:02 EDT
Created attachment 415234 [details]
/var/log/messages file when issue is occurring

I have attached the var_log_wl-messages while this issue has happened, recently I have noticed that the issue happens many times along with a kernel crash (see the traceback below).
********************************
Fedora release 12 (Constantine)
i686
2.6.32.9-70.fc12.i686.PAE
********************************

BACKTRACE
------------[ cut here ]------------
WARNING: at net/wireless/core.c:614 wdev_cleanup_work+0x4a/0xa2 [cfg80211]()
Hardware name: 07686VG
Modules linked in: aes_i586 aes_generic fuse rfcomm sco bridge stp llc bnep l2cap sunrpc cpufreq_ondemand acpi_cpufreq ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 uinput snd_hda_codec_analog snd_hda_intel arc4 snd_hda_codec ecb snd_hwdep snd_seq sdhci_pci iwl3945 snd_seq_device sdhci snd_pcm 8139too iwlcore snd_timer mmc_core 8139cp snd mii iTCO_wdt soundcore iTCO_vendor_support snd_page_alloc mac80211 btusb gspca_sn9c20x bluetooth gspca_main videodev v4l1_compat i2c_i801 cfg80211 rfkill joydev serio_raw dm_multipath firewire_ohci firewire_core crc_itu_t yenta_socket rsrc_nonstatic i915 drm_kms_helper drm i2c_algo_bit i2c_core video output [last unloaded: microcode]
Pid: 9, comm: events/0 Not tainted 2.6.32.9-70.fc12.i686.PAE #1
Call Trace:
[<c0441121>] warn_slowpath_common+0x6a/0x81
[<f90dc46a>] ? wdev_cleanup_work+0x4a/0xa2 [cfg80211]
[<c044114a>] warn_slowpath_null+0x12/0x15
[<f90dc46a>] wdev_cleanup_work+0x4a/0xa2 [cfg80211]
[<c0457a49>] worker_thread+0x140/0x1b9
[<f90dc420>] ? wdev_cleanup_work+0x0/0xa2 [cfg80211]
[<c045b4d5>] ? autoremove_wake_function+0x0/0x34
[<c0457909>] ? worker_thread+0x0/0x1b9
[<c045b29d>] kthread+0x64/0x69
[<c045b239>] ? kthread+0x0/0x69
[<c0409ca7>] kernel_thread_helper+0x7/0x10

******
dmesg output
-------------
iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26kds
iwl3945: Copyright(c) 2003-2009 Intel Corporation
iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwl3945 0000:03:00.0: setting latency timer to 64
iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG
iwl3945 0000:03:00.0: irq 26 for MSI/MSI-X
Comment 3 Tamas Kalman 2010-05-19 16:17:01 EDT
I have upgraded the kernel to 2.6.32.12-115.fc12.i686.PAE, it seems nothing has changed.

BACKTRACE
------------[ cut here ]------------
WARNING: at net/wireless/core.c:614 wdev_cleanup_work+0x4a/0xa2 [cfg80211]()
Hardware name: 07686VG
Modules linked in: aes_i586 aes_generic fuse rfcomm sco bridge stp llc bnep l2cap sunrpc cpufreq_ondemand acpi_cpufreq ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 uinput snd_hda_codec_analog snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm arc4 8139too sdhci_pci sdhci mmc_core 8139cp ecb mii gspca_sn9c20x gspca_main videodev v4l1_compat btusb bluetooth iwl3945 iwlcore iTCO_wdt mac80211 snd_timer snd iTCO_vendor_support cfg80211 soundcore joydev i2c_i801 snd_page_alloc serio_raw rfkill dm_multipath firewire_ohci yenta_socket firewire_core crc_itu_t rsrc_nonstatic i915 drm_kms_helper drm i2c_algo_bit i2c_core video output [last unloaded: microcode]
Pid: 9, comm: events/0 Not tainted 2.6.32.12-115.fc12.i686.PAE #1
Call Trace:
[<c04412e5>] warn_slowpath_common+0x6a/0x81
[<f90e646a>] ? wdev_cleanup_work+0x4a/0xa2 [cfg80211]
[<c044130e>] warn_slowpath_null+0x12/0x15
[<f90e646a>] wdev_cleanup_work+0x4a/0xa2 [cfg80211]
[<c0457c0d>] worker_thread+0x140/0x1b9
[<f90e6420>] ? wdev_cleanup_work+0x0/0xa2 [cfg80211]
[<c045b699>] ? autoremove_wake_function+0x0/0x34
[<c0457acd>] ? worker_thread+0x0/0x1b9
[<c045b461>] kthread+0x64/0x69
[<c045b3fd>] ? kthread+0x0/0x69
[<c0409cc7>] kernel_thread_helper+0x7/0x10
Comment 4 John W. Linville 2010-05-19 16:31:07 EDT
What did you do to get that trace?  By chance, is it related to a suspend/resume event?
Comment 5 Tamas Kalman 2010-05-19 17:00:25 EDT
I have upgraded the kernel to 2.6.32.12-115.fc12.i686.PAE, it seems nothing has changed.

BACKTRACE
------------[ cut here ]------------
WARNING: at net/wireless/core.c:614 wdev_cleanup_work+0x4a/0xa2 [cfg80211]()
Hardware name: 07686VG
Modules linked in: aes_i586 aes_generic fuse rfcomm sco bridge stp llc bnep l2cap sunrpc cpufreq_ondemand acpi_cpufreq ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 uinput snd_hda_codec_analog snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm arc4 8139too sdhci_pci sdhci mmc_core 8139cp ecb mii gspca_sn9c20x gspca_main videodev v4l1_compat btusb bluetooth iwl3945 iwlcore iTCO_wdt mac80211 snd_timer snd iTCO_vendor_support cfg80211 soundcore joydev i2c_i801 snd_page_alloc serio_raw rfkill dm_multipath firewire_ohci yenta_socket firewire_core crc_itu_t rsrc_nonstatic i915 drm_kms_helper drm i2c_algo_bit i2c_core video output [last unloaded: microcode]
Pid: 9, comm: events/0 Not tainted 2.6.32.12-115.fc12.i686.PAE #1
Call Trace:
[<c04412e5>] warn_slowpath_common+0x6a/0x81
[<f90e646a>] ? wdev_cleanup_work+0x4a/0xa2 [cfg80211]
[<c044130e>] warn_slowpath_null+0x12/0x15
[<f90e646a>] wdev_cleanup_work+0x4a/0xa2 [cfg80211]
[<c0457c0d>] worker_thread+0x140/0x1b9
[<f90e6420>] ? wdev_cleanup_work+0x0/0xa2 [cfg80211]
[<c045b699>] ? autoremove_wake_function+0x0/0x34
[<c0457acd>] ? worker_thread+0x0/0x1b9
[<c045b461>] kthread+0x64/0x69
[<c045b3fd>] ? kthread+0x0/0x69
[<c0409cc7>] kernel_thread_helper+0x7/0x10
Comment 6 Tamas Kalman 2010-05-19 17:09:07 EDT
Hi John,

this has occurred when the connection was dropped and while the auto reconnect/resume procedure was popping a dialog to enter the WPA key.

In general that this is happening when there is greater traffic/load on the interface eg. audio/video streaming.

By the way I have tried your suggestion you have posted for FC13 in bug report 589777...

quote:
"Please create a file named /etc/modprobe.d/iwl3945.conf with this one line:

    options iwl3945 disable_hw_scan=1

After that, either reboot or execute this sequence:

   modprobe -r iwl3945
   modprobe iwl3945

Does that produce any better results?"

As for Kyryl also for me this has improved stability so far, but getting the below events every two minutes:

-----------------------------------------------------------------------
May 19 22:57:36 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 100 [0]
May 19 22:57:37 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 104 [0]
May 19 22:57:37 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 108 [0]
May 19 22:57:37 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 112 [0]
May 19 22:57:38 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 116 [0]
May 19 22:57:38 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 120 [0]
May 19 22:57:39 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 124 [0]
May 19 22:57:39 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 128 [0]
May 19 22:57:40 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 132 [0]
May 19 22:57:40 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 136 [0]
May 19 22:57:40 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 140 [0]
May 19 22:59:36 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 100 [0]
May 19 22:59:37 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 104 [0]
May 19 22:59:37 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 108 [0]
May 19 22:59:37 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 112 [0]
May 19 22:59:38 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 116 [0]
May 19 22:59:38 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 120 [0]
May 19 22:59:39 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 124 [0]
May 19 22:59:39 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 128 [0]
May 19 22:59:40 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 132 [0]
May 19 22:59:40 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 136 [0]
May 19 22:59:40 localhost kernel: iwl3945 0000:03:00.0: Failed to get channel info for channel 140 [0]
Comment 7 Stanislaw Gruszka 2010-05-21 07:56:35 EDT
What about kernel 2.6.32.11-102 or newer. Since -102 version we have Intel patches applied for recover from firmware stuck. I believe these patches help with bug.
Comment 8 Stanislaw Gruszka 2010-05-21 10:41:40 EDT
Above comment is for Tomas Henzl.

Tamas Kalman,

Your problem seems to be quite different, please open new bug for it and assign to me. Thanks.
Comment 9 Tomas Henzl 2010-05-21 16:52:14 EDT
(In reply to comment #7)
> What about kernel 2.6.32.11-102 or newer. Since -102 version we have Intel
> patches applied for recover from firmware stuck. I believe these patches help
> with bug.    

I tested the 2.6.32.12-115 with the same result - for dmesg see comment#0.
Comment 10 Stanislaw Gruszka 2010-06-03 04:40:16 EDT
Hi Tomas, could you please try 
http://koji.fedoraproject.org/koji/buildinfo?buildID=173241
it include a new patch that helps similar F13 bug (589777)
Comment 11 Stanislaw Gruszka 2010-06-17 04:47:00 EDT
Ping.
Comment 12 Tomas Henzl 2010-06-18 05:40:43 EDT
I tested the kernel and it worked for me. In dmesg were no interesting messages, nothing about firmware reload etc.
This means it either works or I should have stressed it more:)

I think you can close this for now.
Comment 13 Stanislaw Gruszka 2010-07-13 04:44:47 EDT
kernel-2.6.32.16-141.fc12 has been pushed to the Fedora 12 stable repository. 
If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.