Bug 588094 - nm-applet don`t start nm-connection-editor
Summary: nm-applet don`t start nm-connection-editor
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-02 16:04 UTC by Martin Naď
Modified: 2010-05-04 21:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 21:41:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Naď 2010-05-02 16:04:23 UTC
Description of problem:
when If I right click on nm-applet and click on edit connections nothing happening
to konsole paste:
[martin@starcraftX ~]$ nm-applet 

** (nm-connection-editor:3165): WARNING **: Icon nm-device-wwan missing: V motivu není obsažena ikona "nm-device-wwan"

** (nm-connection-editor:3165): WARNING **: Failed to initialize the UI, exiting...

maybe I have not something installed

Version-Release number of selected component (if applicable):
NetworkManager-pptp-0.8.0-1.git20100411.fc13.x86_64
NetworkManager-openvpn-0.8-2.git20100411.fc13.x86_64
NetworkManager-glib-0.8.0-8.git20100426.fc13.x86_64
NetworkManager-vpnc-0.8.0-1.git20100411.fc13.x86_64
NetworkManager-0.8.0-8.git20100426.fc13.x86_64
NetworkManager-openconnect-0.8.0-1.git20100411.fc13.x86_64
NetworkManager-gnome-0.8.0-8.git20100426.fc13.x86_64

How reproducible:
everytime

Steps to Reproduce:
1.try start connection editor from nm-applet
2.nm-connection-editor not start
3.
  
Actual results:
nm-connection-editor dont start (maybe because some missing dependency)

Expected results:
nm-connection-editor work ok (or add missing dependency)

Additional info:

Comment 1 Dan Williams 2010-05-02 21:40:50 UTC
No, you didn't do anything wrong, but it looks like an update failed to update the gtk icon cache.  Try, as root:

gtk-update-icon-cache -f /usr/share/icons/hicolor

and see if that fixes the issue?

Comment 2 Martin Naď 2010-05-03 11:01:03 UTC
[root@starcraftX ~]# gtk-update-icon-cache -f /usr/share/icons/hicolor
gtk-update-icon-cache: Cache file created successfully.

and now work ok, thanks

Comment 3 Dan Williams 2010-05-04 21:41:11 UTC
Ok, I think this is an issue with the gtk icon cache code; it clearly shouldn't happen but there are already some bugs open for this issue in gtk where the cache gets corrupted for some reason.  We'll track that in the other bugs.  thanks!


Note You need to log in before you can comment on or make changes to this bug.